Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Kenwood KAC-8152D no power
Kenwood KAC-8152D no power
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th May 2008, 03:28 AM   #1
tritron is offline tritron  United States
diyAudio Member
 
Join Date: Jun 2006
Post Kenwood KAC-8152D no power

Last year i got this Kenwood KAC-8152D amp from ebay for cheap and I would like to fix it. The light is off . I am wating for repar manual that i just bought. What place i can start to truble shoot this amp
  Reply With Quote
Old 11th May 2008, 04:04 AM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Q3 may be open.

If you have 13.5v on B+ and you have remote voltage applied, you should have ~13.5 on the emitter of Q3. ~13v on the base and ~13.4 on the collector.
  Reply With Quote
Old 14th May 2008, 06:52 AM   #3
tritron is offline tritron  United States
diyAudio Member
 
Join Date: Jun 2006
I fix it. Looks like one of power wiress came lose and touched power on amp remote input. There was broken trace so i fixed it and now works great. Thank you for your help.
  Reply With Quote

Reply


Kenwood KAC-8152D no powerHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood Power AMP KM-X1 transformer info space2000 Solid State 0 21st June 2008 12:08 PM
kenwood kac8401 no power lalo01 Car Audio 20 24th October 2007 07:34 PM
Looking for a Kenwood L-07MII power transformer Klaude Swap Meet 3 7th February 2007 03:04 AM
How to set Power transistors on Kenwood ka-5500? Lipaso Solid State 24 31st January 2007 02:59 PM
KW-40 by Kenwood power amp/tuner? RMS Analogue Source 5 5th January 2003 11:58 PM


New To Site? Need Help?

All times are GMT. The time now is 07:24 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki