Hifonics Brutus Bxi1206d SFp50N06 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th March 2008, 10:36 AM   #1
ray9043 is offline ray9043  Mexico
diyAudio Member
 
Join Date: Mar 2008
Default Hifonics Brutus Bxi1206d SFp50N06

hi everyone¡

i have a big problem with my amp, is it a Hifonics Brutus Bxi1206d, it don`t work¡ it burn the SFP50n06 FET`s, and 1 IRF640N fet, i change the SFp50n06 and the irf640n, but the amp burn the sfp50n06 again¡ and i don`t know the problem¡

i think the problem is in the resistances of the fet`s, because the amp burn 2 or 3 resistance and i change all resistances, BUT i buy the resistance and i think the employe of the electronic shop, give me the wrong resistance and i don`t have the originals resistance. please, if one of your`s have the same amp, please, give me the value of all resistance of the fet`s

i need the value of the resistances that go to the SFP50N06, they are 8
and i need the value of the resistance that go to the IRF640N, they are 16, 8 of one value and 8 of other value.

please, help me¡ i need to put to working this amp, is new, this amp only work a few days¡

i have a question?¿
Which is the value in volts that it must come to the SFP50N06
in the source, the gate and the drain legs of the fet`s?

other questions?¿
That another component can be trumping and that could be the problem for which they burn the SFP50N06 FETs.?¿?¿

thanks to all¡¡¡
  Reply With Quote
Old 28th March 2008, 04:01 AM   #2
ray9043 is offline ray9043  Mexico
diyAudio Member
 
Join Date: Mar 2008
Exclamation they are the resistances

i found the value of the resistances of them irf640n`s but still I do not have the value of the resistances of sfp50n06`s i show a image to see exactly the resistances.

http://img2.freeimagehosting.net/ima...8f03cb0e1d.jpg

Thank you
  Reply With Quote
Old 29th March 2008, 08:16 PM   #3
diyAudio Member
 
theAnonymous1's Avatar
 
Join Date: Feb 2004
Location: Anonymityville
Not a very good pic. Red, brown, black, gold? 21R?
  Reply With Quote
Old 29th March 2008, 09:32 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Some of the brutus amps used 22 ohm resistors. Measure all of them (with the blown FETs removed). If several are 22 ohms, you know that's the correct value.

Shorted output transistors are the most common reason for the power supply FETs to fail. Check them before applying power to the amp.

Approximate voltages (blown FETs removed):

Gate = ~5v
Drain = same voltage as 12v DC power supply voltage
Source = ground = 0v.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Defect Transistors in Hifonics Brutus BX1500D JoergST Car Audio 98 31st May 2014 12:55 AM
Help me fix Hifonics brutus BXi1206D hakentt Car Audio 55 16th June 2012 06:10 AM
hifonics brutus bxi1206d ray9043 Car Audio 2 30th March 2008 06:36 AM
Hifonics Brutus sounds like ol' shortwave radio valterdaw Car Audio 15 1st January 2007 07:28 AM
Hifonics Brutus BX1000D problems... Knertified Car Audio 1 7th July 2004 01:34 AM


New To Site? Need Help?

All times are GMT. The time now is 02:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2