Blown Volfenhag ZX-7180 Amp - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th March 2008, 05:34 PM   #1
vario is offline vario  Abu Dhabi
diyAudio Member
 
Join Date: Jan 2008
Default Blown Volfenhag ZX-7180 Amp

I bought a blown amp off ebay and had my money completely refunded, however I never had to return the amp to sender.

Its an older Volfenhag ZX-7180, very flee market looking. The amp will power on its lights and the heatsink fan but it does not create any output on the speaker channels.

I opened the amp up and I didnt see any signs of burn on the board however there are a few areas around several transistors that appear to have corrosion on the diodes and resistors leading to them.

Any ideas? Is there a good way to check if these components are what failed? I can post pictures if it helps.
  Reply With Quote
Old 13th March 2008, 06:13 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It sounds like the amp got wet.

Photos would be helpful.

Clean the board with contact cleaner and a toothbrush if the corrosion is heavy.

Checking the components in the board may not tell you much unless they are shorted or open. Leaking diodes and out-of-tolerance resistors can be difficult to find unless you remove one leg from the board.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blown PA lizzardio Solid State 0 1st May 2009 04:36 PM
12" VOLFENHAG subs, any good? buenosdias Subwoofers 9 12th July 2006 01:44 AM
Blown AMp?? zorb_rules Car Audio 0 25th June 2004 08:39 AM
blown sub wharfrat Subwoofers 10 23rd May 2004 05:12 PM
Need spec for KFC-7180 FrankDIY Multi-Way 5 23rd November 2001 03:56 AM


New To Site? Need Help?

All times are GMT. The time now is 08:45 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2