mtx rt 2400 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th March 2008, 06:51 PM   #1
diyAudio Member
 
Join Date: Mar 2008
Default mtx rt 2400

At a very low volume the amp works, but when I turn up the volume the amp cuts in and out. I have bigger amp that i am using now and it works fine. Any suggestions would be great.

thank jt
  Reply With Quote
Old 7th March 2008, 08:27 PM   #2
sdoom is offline sdoom  Germany
diyAudio Member
 
Join Date: Mar 2004
Location: Heidelberg
Could be some bad solder joints on the output stages, when higher current flows through the output transistors the voltage drop on the protection/observation curcuits could be higher because of bad solder joints .
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nad 2400 thx amp schematic steven344 Solid State 4 25th July 2013 06:23 AM
Citronic PPX 2400 Neilgilbert Solid State 4 19th January 2010 05:53 PM
SAE 2400 amp needs help scm Solid State 8 2nd July 2007 11:08 PM
Nad 2400 SillyCone Solid State 4 30th June 2007 09:32 PM
what to do with these caps: 2400 mfd, 450 VDC Jared Parts 12 11th October 2002 06:30 AM


New To Site? Need Help?

All times are GMT. The time now is 03:18 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2