MTX TC6001 repair - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th February 2008, 05:39 PM   #1
diyAudio Member
 
Join Date: Sep 2007
Send a message via MSN to Kevin_Murray
Default MTX TC6001 repair

Hi everyone, I'm new to this section and thought I'd post a question about an amp I've been trying to repair. It's an MTX TC6001 switcher. I've checked the power supply and the output devices and they're all good. I've been tracing the schematic the old fashion way since I read here that MTX doesn't give them out. So far I've replaced a bad regulator circuit for the opamp rails (zener+transistor) but it still does not work. I've got a new NE5532 opamp on order since I found one that gets so hot it reflows on it's own. Might be what blew the opamp rail regulator. Anyone have any ideas what else to check before I power up with the new parts installed? Thanks for any help.
__________________
Kevin Murray
  Reply With Quote
Old 13th February 2008, 05:52 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Can you post a photo of the inside of the amp?

If possible, send me a high resolution version at:
babin_perry@yahoo.com
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY Car Repair avatar307 The Lounge 6 22nd May 2011 10:19 PM
DHD should repair? Solosound Car Audio 5 9th November 2008 07:39 PM
Amp repair ddino77 Solid State 1 9th December 2007 03:50 AM
Amp repair help 2SickBassist Solid State 2 18th May 2006 08:44 AM
Help for repair my KSA 100 Alex helge Solid State 76 23rd October 2003 03:38 PM


New To Site? Need Help?

All times are GMT. The time now is 04:25 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2