diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   Channel volumes differ on Mobile Authority 120ZX amp (http://www.diyaudio.com/forums/car-audio/116806-channel-volumes-differ-mobile-authority-120zx-amp.html)

KyferEz 4th February 2008 06:00 PM

Channel volumes differ on Mobile Authority 120ZX amp
 
A while back I fixed this amp's outputs and now it preforms ok, but not perfect. However, I got busy with other work and placed it aside for a while. I need to finish it. The problem is that the 2 right channels are at a lower volume level than the 2 left channels even though the gain controls are at the same position.

Here are some pictures of the amp:
http://i210.photobucket.com/albums/b...s/IMGP2291.jpg

http://i210.photobucket.com/albums/b...s/IMGP1323.jpg

I'm too new in fixing amps to know how to correctly address this problem. I assume it has to do with the 4 pots in you can see on the board, one per channel; but what's the best way to make adjustments and get the outputs all equal? I have a scope, so if that's needed here I'm ready to go.

Thanks!

Perry Babin 5th February 2008 03:23 AM

Have you looked at the output of all channels to confirm that they are clean and not clipped or otherwise distorted?

Have you tried getting a schematic from MA?

If they won't provide one, you need to apply signal to one channel at a time and map out the path for each channel in the amp. Mark pins 1 and 7 on each op-amp so you know which channel they are in. Then you'll need to compare the levels at each stage to see where it's goes low.

If both left channels are precisely the same and both right channels are precisely the same, this could be a manufacturing defect. If that's the case, you may have to change the value of a couple of resistors to get the channels equal.

KyferEz 5th February 2008 05:07 AM

I can't get their website to load, so am not sure how to contact MA.

I have looked at the outputs using a 440hz tone as input. Clean output.

I went a step further, and measured the outputs, no load. Wasn't sure if I should have a load for testing this... Anyway, I'm getting the following results with identical gain settings:
Left Front is ~ 0.8Vpp lower than Right Front
LF=21.6 RF=22.4

Left Rear is ~0.4Vpp less than Right Rear
LR=21.6 RR=22.0

Doesn't seem like much, but I heard it...

Thanks!

Perry Babin 5th February 2008 05:18 AM

This is less than 1/3 of a dB. For most people, this difference would be absolutely inaudible. You won't get better than this without having individual pots for each channel.

Do you get the same difference at ~3v output (2.2v/3v)?

KyferEz 5th February 2008 12:27 PM

With a woofer connected it sounded more substantial... I'll try the test with a load.

At low outputs the difference is much smaller. The difference scales with output levels. If you want actual measurements let me know.

Thx!

Perry Babin 5th February 2008 12:34 PM

If the difference really is audible, maybe the difference in output is due to a difference in the frequency response between left and right. Measure the output at lower frequencies (50-100hz).

KyferEz 5th February 2008 02:17 PM

I think it's just a manufacturing issue. One 072BD dual opamp drives the LF and LR channels, and another drives the RF and RR channels. And that corresponds somewhat to the results below.

I did a test at low power with a 4ohm load with 80Hz and here are the results:
RF=4.7Vpp 1.125A
LF=4.3Vpp 1.100A
LR=4.3Vpp 1.100A
RR=4.5Vpp 1.125A

Thx!

Perry Babin 5th February 2008 04:46 PM

That's still less than 1dB. Maybe it's worse when you turn on the bass boost?

Are you using the same RCA signal line for all channels during testing?

KyferEz 5th February 2008 06:58 PM

There's no bass boost on this amp. Yes, I'm using the same signal line for all channel tests.

I guess it's nothing really to worry about... It wasn't easy to hear the difference, but upon switching the woofer back and forth, I could hear it.

Unless you suggest otherwise, I'm going to button it up and move on to the next one. Unfortunately it's likely to be more difficult.

Perry Babin 5th February 2008 07:11 PM

I certainly wouldn't be concerned about a diffference of less than 1dB.

Start a new thread if you need help with another amp.


All times are GMT. The time now is 06:09 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2