Brax amplifier help (no output) - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th January 2008, 01:32 AM   #1
MCD007 is offline MCD007  United States
diyAudio Member
 
Join Date: Jan 2008
Default Brax amplifier help (no output)

Hello all,

I was referred here a place where I could find help with my Brax amp. Since Brax is no longer sold or supported in the US I have had a tough time finding someone local or otherwise to repair the amp.

The model is the SPL competition and it powers fine (green lights all around) but there is no sound output. I ruled out the source signal to verify that in fact it is the amp that is the problem.

I would like to try my hand at repairing this if possible. Any help would be appreciated.


thanks
  Reply With Quote
Old 8th January 2008, 02:29 AM   #2
jol50 is offline jol50  United States
diyAudio Member
 
Join Date: Nov 2007
Did you move the RCAs a little if possible (loose connector), use all the controls to see if they had a bad solder/etc.? Lift the cover and look for anything burnt? With a digital meter what is millivolt of the speaker leads for each channel and bridged if you run the amp with nothing hooked to it, just power?
  Reply With Quote
Old 8th January 2008, 02:48 AM   #3
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
Sunnyvale ?? Like in Bay area ?? I live there. LMK I have worked on smaller Brax amps in the past....


By the way which model do you have???
  Reply With Quote
Old 8th January 2008, 05:08 AM   #4
MCD007 is offline MCD007  United States
diyAudio Member
 
Join Date: Jan 2008
jol50: It slowly began losing its output over a 3 month period. I checked for loose connections and burnt areas. But I am not sure whether the back side is burnt or just flux residue. I will try the millivolt test to see what I get.


Justonemoreamp: Yea sunnyvale in the bay area. That would be sweet if you could help me out. The model I have is the SPL Competition. Its rare compared to the X#### models.
  Reply With Quote
Old 8th January 2008, 05:32 AM   #5
jol50 is offline jol50  United States
diyAudio Member
 
Join Date: Nov 2007
I had one that would lose power at times then stayed that way, some of the transistors came unsoldered in the outputs. PPI lays them right on top of the board and they came off.
  Reply With Quote
Old 8th January 2008, 05:43 AM   #6
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
e-mail sent...
  Reply With Quote
Old 8th January 2008, 06:51 AM   #7
MOER is offline MOER  United States
diyAudio Member
 
Join Date: Aug 2003
Location: SIMI VALLEY CA
Default Brax

We can repair this amplifier for you.

Email me at zedaudio@aol.com

Steve
  Reply With Quote
Old 9th January 2008, 01:21 AM   #8
diyAudio Moderator Emeritus
 
lumanauw's Avatar
 
Join Date: Oct 2002
Location: Bandung
Send a message via Yahoo to lumanauw
Quote:
Since Brax is no longer sold or supported in the US I have had a tough time finding someone local or otherwise to repair the amp.
What happened with Brax in USA?
  Reply With Quote
Old 9th January 2008, 03:28 AM   #9
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
news to me also, but things change fast is car audio, so who knows....ZED will fix him up....
  Reply With Quote
Old 10th January 2008, 12:59 AM   #10
Clipped is offline Clipped  Thailand
diyAudio Member
 
Join Date: Mar 2005
Location: home
Send a message via MSN to Clipped
autofile at carsound.com is the importer
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brax, Helix Schematic senee Car Audio 2 1st February 2008 05:42 PM
Amplifier output question Flyin11 Car Audio 32 18th December 2007 07:04 PM
Amplifier Output Distorted Rotellian Solid State 12 10th May 2006 01:49 PM
Brax "Graphic Pro" ever heard of em? is this a joke? lol SkinnyBoy The Lounge 0 28th March 2003 05:44 PM


New To Site? Need Help?

All times are GMT. The time now is 03:28 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2