Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd December 2007, 06:27 AM   #11
marko is offline marko  United Kingdom
diyAudio Member
 
Join Date: May 2004
Location: donnyuk
i just repair amps for my own personal collection and a hobby, i will be replacing all the units at some point but for now it's up and running and sounding superb

i need to put a big order in with jandrelectonics as i've got a faulty continuum on it's way and this will have everything done right 1st time!! (i'm guessing this has tip102/107 combo too?)
  Reply With Quote
Old 23rd December 2007, 07:43 AM   #12
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The continuum is based on the reference 705 which uses the 102 and 107. There were a few amps that used the TIP142T and TIP147T (which were rated at higher current). Since the continuum was a special edition amp, you may want to wait for it to arrive before ordering parts. It may have used the 142T and 147T.

Justonemoreamp knows more about the SS amps than I do, maybe he can tell you which ones they used.
  Reply With Quote
Old 23rd December 2007, 07:48 AM   #13
marko is offline marko  United Kingdom
diyAudio Member
 
Join Date: May 2004
Location: donnyuk
don't let him here you calling him "justonemoreamp"!!! you mean onemoreamp aka cecil

yeah, cecil is a good friend of mine over on the phoenix forums.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundstream 405 sub-channel Problem,plz help! cgpeanut Car Audio 26 7th September 2008 06:40 PM
Problem with Soundstream MC 140 cdo Car Audio 0 20th May 2008 07:20 PM
problem with soundstream class 5.2 marko Car Audio 0 16th September 2006 09:43 PM
Soundstream Reference 300 Problem notacop Car Audio 12 21st February 2006 11:24 PM
soundstream reference 405 problem suprmanDL Car Audio 3 21st January 2005 07:46 PM


New To Site? Need Help?

All times are GMT. The time now is 04:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2