diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   The Good. The Bad and the Ugly Car Amps (http://www.diyaudio.com/forums/car-audio/113473-good-bad-ugly-car-amps.html)

boxcustom 12th December 2007 12:55 AM

The Good. The Bad and the Ugly Car Amps
 
Hello. I have been selling car amplifiers for 30 years or so. I would like to get opinions from you on your most Favorite Car Amplifier (The Good). Your most disliked car Amplifier (The Bad). And the most Ugly car Amplifier you have had the chance to use or see.
I will start with my favorite. The Good. It has to be the original Rockford Fosgate punch 150 circ. 1980. The Bad. Pioneer GM amplifiers from the same era. I hate the din connection and the crazy turn on section. The Ugly. Chrome MA audio with the rack mount handles and large Vu meters.
These are subjective opinions. I am just trying to have a little late night fun with the car audio forum users. Thanks!

ocool_15 12th December 2007 01:29 AM

My favorites Cosmetically:
Phoenix gold tantrum series from '02-03(They looked the same for several more years)
Rockford Fosgate 2003 Power series- blue logos, but they were similar for a few years
Memphis Audio amps like the MC1000D

Flyin11 12th December 2007 01:53 AM

My favorite amplifiers (I have 3 now):

MTX (Thunder series from the 90's)
PPI Sedona Series (From the 90's)
Alpine

Disliked:

Cheap non brands like Radio Shack and stuff...

Ugly:

It worked really good and had great sound but my brother gave me a Sherwood from the 80's back in like 92 and man that thing was the size of a centerblock!!! It was big and ugly and got really hot really quickly!!

skooter 12th December 2007 02:43 AM

Liked the look of the old school rockfords punch 45, 75, 150
old kenwoods and now I love my PPI PCX2200

had a pyrimid and when it tuned on it would THUMP really bad and it got really hot

Uglyest, would have to be Power costic and the sony exsplod.

klimaudio 12th December 2007 03:06 AM

My Favorite Amp

A/D/S 860MX

No cheesey graphics....low profile and highly configurable for the time. 8 channels with multiple crossover and each pair was bridgeable. Too bad somebody wanted it more than I did...it was liberated from my trunk about 5 years back.

Hotsauce 12th December 2007 03:13 AM

For Good, I have to go with Milbert on sound, and the old school Xtant for looks.

I've really not had any bad car amps.

Ugly: I would pick the ones with chrome flames..The brand escapes me.

John C.

454Casull 12th December 2007 03:45 AM

http://www.audiobahn.com/Audiobahn06/pages/amps.html

jol50 12th December 2007 03:52 AM

Good- the linear power and coustic from early 80s, black mostly and all business. The RF punch were great amps too but I like old alpines the most for some reason, funny they didn't seem to make big amps back then. I even had an old pyramid that was good from back then. A/D/S are nice also.

Bad- sanyo, had one and it sucked back then. Had the fins on the sides and was black. Yes the pioneers were problematic with noise issues too, what was the big one the GM120? They had no line voltage. Any amp with DIN only connection sucked too, including the alpines I like that I use RCA adapters on....and that one does not even have a gain on it! But it sounds great.

Ugly- many of the new amps are to me, some just look so....well I wont say that. Others look useless with no heatsinks. I just fixed a dub with the heatsink inside the amp, how stupid can you get. If you can't tell I like function first, but form can be even with it. Actually the cheap dub looks ok other than not having an external heatsink and the goofy fake grill on top. Even the audiobahn intake amps with the fan don't really blow the fan over the heatsinks, I don't get it. Seem to work ok given the price. I don't care for flash but the chrome looks nice on those. The red sony explod that look like a blob, I hate those for looks.

tsmith1315 12th December 2007 04:29 AM

Quote:

Bad- sanyo, had one and it sucked back then. Had the fins on the sides and was black
Sanyo PA6100/6110, with "speaker protection circuit" that NEVER worked.

Tough thread...

Good (choose only one?):
Zapco 200A.

Bad:
It's hard to argue with that Pioneer GMA120.

Ugly:
Anything that doesn't look like an amplifier. Sorry guys, I'm old.

Tim

ppia600 12th December 2007 05:01 AM

Good - Any american made ppi, Linear power, adcom, Phoenix Gold, or any japan made alpine

Bad - power acoustik, rockwood, kenford, and any other amp that copies its name from good companies

Ugly - old coustics (the 190 and 380, but they did have good bang for the buck) and any of the chrome plated neon glowing led flashing vu meter amps. Hell, even the macIntosh amps look gawdy to me, and they are supposed to be great performers


All times are GMT. The time now is 11:35 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2