PPI A600 Transistors? c2344 and a1011 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th June 2007, 03:27 PM   #1
diyAudio Member
 
Join Date: Jun 2007
Default PPI A600 Transistors? c2344 and a1011

Does anybody know what the replacements for these are? I have nte398 for a1011 and nte375 for the c2344. Is this correct? I know there is some Art Series fanatics out there! Thanks.
  Reply With Quote
Old 28th June 2007, 11:39 PM   #2
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
you should do a search using your browser to find these. they are fairly common place at ampslab here :

http://www.ampslab.com/trans_2sa1011.htm

plus other places like www.acecomponents.com , and many other places even here on this forum under the market place and electronics and parts .
if you have to they most probably can be replaced with the same device as the outputs, or a TIP-41C & 42C as I have seen in many other amps like Hifonics etc.... its the insulated case thats special about that device make sure you have insulators underneath it if you use a replacement that has a metal base.


hope this helps
  Reply With Quote
Old 29th June 2007, 01:11 AM   #3
diyAudio Member
 
Join Date: Jun 2007
Thanks for the help! I checked the specs and everything looks good. I checked the thermal compound in the case and there was a insulator in there. Looks like maybe they have been replaced before? Anyway I appreciate the help.
  Reply With Quote
Old 30th June 2007, 03:26 PM   #4
ppia600 is offline ppia600  United States
diyAudio Member
 
Join Date: Jun 2007
Location: Louis y ana
Great amplifier, I have one running my four mids and tweeters, I wish I hadn't sold my last one.
  Reply With Quote
Old 30th June 2007, 06:02 PM   #5
diyAudio Member
 
Join Date: Jun 2007
It is nice. I'm just waiting for parts now. I can't wait to get it up and running. I'm replacing the a1011, c2344, fesf8dt, bdt81, bdt82, and irfz34 components. I figure i might as well do all these while I'm in there. I'm using nte398 and nte375 to replace a1011 and c2344. NTE597 will replace the fesf8dt. I found IR irfz34, bdt82, and bdt81. I wanted to use irfz44 for the irfz34 but I could not find them except for bulk. Does this sound like it will work?

Thanks,

Corradolvr, CET
  Reply With Quote
Old 30th June 2007, 09:44 PM   #6
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
yeah you can use Z44's instead of Z34's with little issue
  Reply With Quote
Old 30th June 2007, 10:51 PM   #7
diyAudio Member
 
Join Date: Jun 2007
Does everything else look alright? I checked the specs, but if anyone else knows better let me know. Thanks.
  Reply With Quote
Old 1st July 2007, 03:13 AM   #8
ppia600 is offline ppia600  United States
diyAudio Member
 
Join Date: Jun 2007
Location: Louis y ana
Yeah, but I'd definately replace all of the output transistors at the same time, at least for the bad channel. I'm sure someone already said it, but try to get them all from the same batch with same date codes stamped on them. Also be sure to replace all of the power supply transistors at the same time, it will definately be worth it and cheaper in the long run because you won't be replacing them again.
  Reply With Quote
Old 1st July 2007, 06:30 PM   #9
diyAudio Member
 
Join Date: Jun 2007
I'm just gonna replace everything in there. I figure it can't hurt. It will be a fine running machine when I get it done. I'll put it on the service monitor and and give it a thorough test.
  Reply With Quote
Old 3rd July 2007, 02:44 PM   #10
diyAudio Member
 
Join Date: Jul 2007
Send a message via MSN to kainoasun
Hey Corradolvr.... How much did all the transistors cost? I'm trying to get a ball park figure before I send my A600 in to get fixed. I'd do it myself but don't have experience fixing electronics..In my post you said your PPI was like new after replacing the transistors so I may recommend your part numbers when I send it in.

BTW, I've been a Corrado lover since 1989!! Had three since then. Got an old school G-60 in my garage that my PPI came out of. So my experience is more in wrenching and tuning rather than electronics.

Have a great day....Spoilers up!

JK
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PPI A600 problems Riveted1 Car Audio 5 29th January 2009 08:35 PM
Ppi A600 npenson Car Audio 4 27th August 2008 10:36 PM
Still trouble with the A600 corradolvr Car Audio 6 19th July 2007 04:56 PM
Help with a damaged PPI A600.2 punchpeanut Car Audio 7 16th February 2004 05:30 PM


New To Site? Need Help?

All times are GMT. The time now is 11:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2