PPI A600 Amp Schematic - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th June 2007, 07:15 PM   #1
diyAudio Member
 
Join Date: Jun 2007
Angry PPI A600 Amp Schematic

Does anyone know where I could get a schematic for a PPI A600 art series ammplifier. I have one that has a perfect case but it doesn't work. It powers up but I have no audio. Maybe someones ran into this before?
  Reply With Quote
Old 18th June 2007, 08:02 AM   #2
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
Please see the last post in this thread please THX

Precision Power Ax606.2
  Reply With Quote
Old 18th June 2007, 02:06 PM   #3
diyAudio Member
 
Join Date: Jun 2007
Default PPI

Ouch. Thanks man
  Reply With Quote
Old 18th June 2007, 02:09 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you have both positive and negative rail voltage on the outputs?

Do you have pos and neg regulated voltage on all of the op-amps?
  Reply With Quote
Old 19th June 2007, 06:48 AM   #5
diyAudio Member
 
Join Date: Jun 2007
I have not got it on my bench yet. I am a CET so I figure I'll take it to work with me and work on it there. I just did some really rough troubleshooting and figured a schematic would be a big help.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PPI A600 improvement manina Car Audio 7 3rd April 2009 03:16 AM
PPi A600 noise MHFidelity Car Audio 5 29th September 2008 06:13 AM
Ppi A600 npenson Car Audio 4 27th August 2008 10:36 PM
Help with a damaged PPI A600.2 punchpeanut Car Audio 7 16th February 2004 05:30 PM


New To Site? Need Help?

All times are GMT. The time now is 10:41 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2