Amp problems - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th June 2007, 06:25 AM   #1
diyAudio Member
 
Join Date: Jun 2007
Default Amp problems

Hello, I am new to all of this and any help would be greatly appreciated. I recently had a kicker kx 700.5 go into protection. When it went into protection all my audio gear shut off. The head unit came back on but my other amp a Soundstream VGA1600.2 powered on with no output. I pulled the cover on the SS and 2 wires on a torroid were broken just above the board. I replaced the torroid and it still won't work. Both the rail voltage lights come on (+ and -). Now on to the Kicker! I looked at the Kicker for the obvious and found nothing. I have since upgraded, but would love to have the Big SS back pushing my 15's. As for the Kicker it would be nice to have for the girlfriends car. Is there anybody that would be interested in repairing these if it is over my head (which I am sure it is)????
  Reply With Quote
Old 17th June 2007, 07:19 AM   #2
diyAudio Member
 
Join Date: Jun 2007
Somebody throw me a bone please! I am a newbie and need help!
  Reply With Quote
Old 17th June 2007, 10:43 PM   #3
KyferEz is offline KyferEz  United States
diyAudio Member
 
Join Date: Apr 2004
Location: Wilmington, NC
You could always search the net for amplifier repair. Here's somewhere you can send them: http://www.db-r.com/repairs/index.html

Note I'm not affiliated, and haven't used them before, but based on info on their site, I would def. consider them if I couldn't fix an amp myself.
  Reply With Quote
Old 19th June 2007, 04:30 AM   #4
diyAudio Member
 
Join Date: Sep 2006
id be inrested in fixing thoose amps for u since i have all the parts for both of them laying around and i would give u an estimate before any work is done if inrested please let me know my email is fosgate20012001@yahoo.com by the way i live in michigan and both amps would be about $60.00 to $75.00 plus parts to fix if interested please let me know
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GFA-565 problems ben62670 Solid State 5 14th August 2008 06:36 AM
HK AVR 335 Problems utjay2008 Solid State 0 21st October 2007 02:26 AM
Sub Amp Problems Thanks! crippledchicken Solid State 2 10th January 2007 06:17 PM
JLH problems serosmaness Solid State 11 2nd November 2004 06:17 PM
RFI problems laz Solid State 3 21st February 2004 07:06 AM


New To Site? Need Help?

All times are GMT. The time now is 10:23 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2