Go Back   Home > Forums > Blogs > DigitalJunkie

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Rate this Entry

Old Majestic Car Amp

Posted 2nd September 2011 at 01:00 AM by DigitalJunkie

I got this amp in 'fried' condition from a friend many years ago. I finally managed to get it working,and I've been using it for my subwoofer amp ever since,probably about 10 years now? It's not the greatest amp,but it has served me very well on sub duty.

It claims to be 200W per channel, and bridgeable to 400W. It might even pull that off,on a good day.

Anyways,I had some very poor scans of the schematic for this amp(which I later discovered was almost identical to a 4 channel Rockwood amp.) I managed to re-draw the basics,and thought I'd post it up for the forum to check out.

I've been thinking of taking this amp to the bench to do some tests,and maybe some tweaks. I'm all ears if anyone has any thoughts?

Here's a link to the redrawn schematics,I might put the original scans in there also.
Some component values are missing,I was going from memory,and what I could make out from the original scans.

MA-9400 pictures by Nothing40 - Photobucket
Posted in Uncategorized
Views 1006 Comments 0 Email Blog Entry
Total Comments 0

Comments

 
Hide this!Advertise here!

New To Site? Need Help?

All times are GMT. The time now is 11:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2