Turntable giving out too much treble. - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th April 2007, 06:48 AM   #1
diyAudio Member
 
Join Date: Apr 2007
Default Turntable giving out too much treble.

Hello

I have a Numark TT200 table and a cheap little no-name preamp that hooks into my mini system. When I play music, most of it sounds great, until it gets to the more noisy parts of the songs. Then, the vocals, especialy S and T sounds, as well as some of the cymbal work, will sound distorted. I don't know much about vinyl yet so I don't know if it's the preamp or what.

Any ideas?
  Reply With Quote
Old 4th April 2007, 10:05 AM   #2
EC8010 is offline EC8010  United Kingdom
diyAudio Moderator Emeritus
 
EC8010's Avatar
 
Join Date: Jan 2003
Location: Near London. UK
It's the stylus mistracking and damaging the record. That could be because:

The stylus is dirty (carefully clean with isopropyl alcohol and soft brush).
The stylus is worn (replace).
The arm/cartridge is poorly set-up (do a search and find out how to set up an arm/cartridge).
The cartridge is rubbish (replace with something better).
The arm AND cartridge are rubbish (buy decent cartridge but make crude-looking but perfectly functional wooden arm - do search).

Finally, it could just be the electronics, but it's unlikely...

Oh, and welcome to the forum.
__________________
The loudspeaker: The only commercial Hi-Fi item where a disproportionate part of the budget isn't spent on the box. And the one where it would make a difference...
  Reply With Quote
Old 5th April 2007, 01:49 AM   #3
diyAudio Member
 
Join Date: Apr 2007
Thank you for your input. I'll get on the issue ASAP and I'll try to avoid using the records that I like to test this out.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TV PSU giving me nightmares Archimedes Analogue Source 11 26th August 2009 10:59 PM
my SY CCS is only giving me 15mA Shoog Tubes / Valves 17 6th March 2006 07:43 PM
Giving them the horn? JRKO Multi-Way 7 3rd July 2004 05:49 PM
not giving up on the SOZ MEGA_amp Pass Labs 3 19th May 2004 08:33 PM


New To Site? Need Help?

All times are GMT. The time now is 07:50 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2