Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Help
Help
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd April 2005, 11:06 AM   #1
JKennedy87 is offline JKennedy87  United States
diyAudio Member
 
Join Date: Apr 2005
Location: Florida
Send a message via AIM to JKennedy87
Default Help

I need some help please. What should I do to this to make it work good?? ITs my Dad's old PL-115D pionner record turntable one so I dont know whats been done to it before. I just bought a new Styli. For some reason when I plug the player's audio cords in to a reciever it wont come out of my speakers...
  Reply With Quote
Old 2nd April 2005, 12:57 PM   #2
Carondimonio is offline Carondimonio  Switzerland
diyAudio Member
 
Carondimonio's Avatar
 
Join Date: Jun 2004
Location: Bern
Hi,

which receiver input did you plug your TT into?
  Reply With Quote
Old 2nd April 2005, 08:44 PM   #3
JKennedy87 is offline JKennedy87  United States
diyAudio Member
 
Join Date: Apr 2005
Location: Florida
Send a message via AIM to JKennedy87
Default help!

i tried aux and phono i believe...i will go try them again right now
  Reply With Quote
Old 2nd April 2005, 09:13 PM   #4
JKennedy87 is offline JKennedy87  United States
diyAudio Member
 
Join Date: Apr 2005
Location: Florida
Send a message via AIM to JKennedy87
Default nevermind

nevermind i got it to work I just had to use the ground chassis lol.....thanks though
  Reply With Quote

Reply


HelpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 03:04 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki