diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Analogue Source (http://www.diyaudio.com/forums/analogue-source/)
-   -   Technics SL-J90 troubleshoot (http://www.diyaudio.com/forums/analogue-source/48631-technics-sl-j90-troubleshoot.html)

Samson 30th December 2004 08:33 AM

Technics SL-J90 troubleshoot
 
Hi

Have just received the above turntable from a reluctant and now angry dad. It WAS working, then i touched it, and now it doesn't. Have just started record collection and know nothing of these things... searched high and low on net before finding you lot, who seem to know your stuff. Any advice gratefully received...

Here's the problem: Everything seems to be going fine until..... the arm lowers and the needle finds the start of the first track. Then, it slides quickly towards the middle and skates around there - never staying in the groove.

I've taken it apart but can't see anything wrong - although don't really know what i'm looking for. The old man reckons i've "knocked it" and upset the "delicate balance system", but I can't see a way of rebablancing/recalabrating the balance of the arm.

He's going to kill me....

Please help if you can!

Si

ps. don't usually do forums - is this a new thread? apologies if not

Netlist 30th December 2004 09:53 AM

From pictures I've seen of the turntable, there's really not much if anything to adjust on the outside.
I think it's probably only a broken needle.

/Hugo:)


All times are GMT. The time now is 09:33 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2