Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th September 2004, 07:42 PM   #1
diyAudio Member
 
Join Date: Sep 2004
Location: seattle
Default TT ground Question

OK, I recently bought 2 DJ style TT's, Gemini XL-500mk2's, theyre Technics 1200 knock offs. They both work great, except one has a 60Hz hum like a mofo. I know how to ground them, Ive tried every thing I can think of. So I opened it to look inside at the ground post, every thing looks fine, no broken wires, BUT, There is no wire soldered to the ground post of the incoming power cord. My question is twofold, 1) If I connect the ground post of the incoming power cord to the ground post next to the RCA outs, will that eliminate the hum, and 2) If not, will that F something up?
Thanks in advance for any advice.
BTW, I love this site!
  Reply With Quote
Old 17th September 2004, 11:48 AM   #2
diyAudio Member
 
Join Date: Feb 2002
Location: Belgium
First check if there is continuity from your ground point to the arm and shell. The wire may be broken inside the arm.
  Reply With Quote
Old 17th September 2004, 11:52 PM   #3
diyAudio Member
 
Join Date: Sep 2004
Location: seattle
Okay
  Reply With Quote
Old 29th September 2004, 05:59 PM   #4
satyr19 is offline satyr19  United States
diyAudio Member
 
Join Date: Dec 2003
Location: Chicago
Send a message via AIM to satyr19
Ive seen an audio shop put on a cartridge on my turntable and the first time it hummed really bad because of a bad connection of the wire clips to the cartridge itself. Try playing with those.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ground Bus question KT Parts 0 28th March 2006 02:09 AM
GC PCB Ground Question Gcollier Chip Amps 0 18th June 2004 11:08 AM
Pin 7 to ground question for IGC Stever Chip Amps 6 8th November 2003 07:57 PM
does connecting mains ground with circuit ground create a ground loop? jarthel Everything Else 0 25th June 2003 12:55 PM


New To Site? Need Help?

All times are GMT. The time now is 12:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2