Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Cambe : 774 problem
Cambe : 774 problem
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th May 2004, 09:15 AM   #1
sreten is offline sreten  United Kingdom
R.I.P.
 
Join Date: Nov 2003
Location: Brighton UK
Default Cambe : 774 problem

Quote:
Originally posted by Cambe
Hello Everyone,
I have a Pioneer PLC-590 turntable with a Mission 774 tonearm
mounted. The arm needs new cables for the counter weights. I
have been thinking about finding someone who ties fishing fies
to make them. I don't have the arm's instructions anymore so I
really don't know the length it should be.
Sincerely,
Cambe
A picture paints a thousand words - hopefully,
the weight arm should be horizontal when the
arm is in the lead out groove of a record.

sreten.
Attached Images
File Type: jpg 774bias.jpg (14.1 KB, 134 views)
  Reply With Quote
Old 18th August 2005, 04:38 PM   #2
Trevo is offline Trevo  Canada
diyAudio Member
 
Join Date: Aug 2005
just measured both pieces of my broken thread....41.5 mm effective length (excluding end loops)...hope this helps
  Reply With Quote

Reply


Cambe : 774 problemHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mtx amp problem [[help!!]] fuzzypinkhat45 Car Audio 3 8th July 2008 06:34 AM
FRD/ZMA Problem Twisted85 Multi-Way 5 4th December 2006 02:19 PM
p3a problem MaXiZ Solid State 17 16th July 2005 08:14 AM
GC amp problem Jamh Chip Amps 30 6th April 2004 03:50 PM


New To Site? Need Help?

All times are GMT. The time now is 03:09 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki