Technics SP-10 Mk2A, a project by 6L6 - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th September 2014, 03:19 PM   #1
6L6 is offline 6L6  United States
diyAudio Member
 
6L6's Avatar
 
Join Date: Oct 2010
Location: Denver, Colorado
Default Technics SP-10 Mk2A, a project by 6L6

Click the image to open in full size.
(The funny widgets are the motor hub fixing plates)

No, you are not seeing double.

This is my newest and most ambitious project yet - Technics SP-10Mk2A. Neither have a PSU, but that's not a difficult thing. Happily, both are operational, I tested them today with a friend's PSU. One has a fiddly main switch. Both are in sorrier cosmetic shape than I thought. That may prove an issue, only time will tell.

So will I make one good one from the ashes of two? I have no idea yet. Of course, having two at the end of this is always more attractive of an option. I do, however, think I may make one black, that would look quite sharp.

On the to-do list -

Re-cap the main board.
Build PSU
Adjust main board and switches as needed.
Figure out if I have one good table or two.
Build plinth(s).
Address cosmetic issues.
Determine if I can get a long armwand for my Graham, or just get a 10.5" Jelco.
Etc...



So let's get started --



Like I mentioned, both tables are operative, the biggest concerns (other than the need to build PSUs for both) is purely cosmetic.

So let's look at the tables as I received them. These photos intentionally are showing all the warts as ugly as possible.

Click the image to open in full size.
The prettier one. Not bad generally, but the marring and corrosion is all on the 'close' side of the table where it will be seen.

Click the image to open in full size.
The text can be re-filled. the corrosion is fairly shallow.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.
A couple of nicks in the black paint. No big deal.

Click the image to open in full size.
Marring on the paint, no corrosion.

Click the image to open in full size.
Inside the brake section is very clean, and there is plenty of friction material (felt) on the band.

Click the image to open in full size.
I have no idea if this is a lot of wear or not on the hub. I thought it worth a photo, to see if anybody can compare.

Click the image to open in full size.
The platter of the prettier one.

Click the image to open in full size.
A bit of corrosion, nothing severe at all.

Click the image to open in full size.
The stock platter mat had something glued to it. I have no idea hot to get a hard adhesive residue removed from rubber...

Click the image to open in full size.
  Reply With Quote
Old 9th September 2014, 03:53 PM   #2
6L6 is offline 6L6  United States
diyAudio Member
 
6L6's Avatar
 
Join Date: Oct 2010
Location: Denver, Colorado
Click the image to open in full size.
The uglier one.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.
Yes, this one is not as pretty.

Click the image to open in full size.

Click the image to open in full size.
That's down into the metal.

Click the image to open in full size.
The platter is certainly worse.

Click the image to open in full size.

Click the image to open in full size.
This is 30 seconds with steel wool, so it's obvious that it will clean up.


Now the thing that is completely obvious to me after taking the photos and looking into them it that the 'damage' is, in fact, purely cosmetic. They got lightly wet on the top surface and were in a place that was damp or humid so that water had a chance to penetrate and corrode. But it is completely contained on the top surfaces.
  Reply With Quote
Old 9th September 2014, 04:04 PM   #3
6L6 is offline 6L6  United States
diyAudio Member
 
6L6's Avatar
 
Join Date: Oct 2010
Location: Denver, Colorado
The good news - The insides are gorgeous. (This happens to be the innards of the uglier one. )

Click the image to open in full size.
Really, it's very clean. I'm still going to replace all the electrolytics, they get ravaged with age, so replacing them should last another 30 yr.

Click the image to open in full size.
It's 30-someting years old... a few cobwebs are part of the character.

Click the image to open in full size.
About the only thing really showing it's age are these PVC tubes as insulation, it's breaking down a bit and weeping oily stuff.

Click the image to open in full size.
This is neat - the edge connector's clips actually fold out, so there's very little stress when using the plugs.
  Reply With Quote
Old 9th September 2014, 04:06 PM   #4
AVWERK is offline AVWERK  United States
diyAudio Member
 
Join Date: Jan 2004
Location: So Calif.
You can have it bead blasted (glass) if it's not to deep.
The deeper one depending on the thickness could be belt sanded down just below the inter granular corrosion.
Used to see this on Lockheed Jetstar interior fuel tanks.
Using a belt sander on the plinth area is a little crude but will work if you distribute the load over a large area.
You could finish up with a sanding block to get the final look.
And no, we didn't,t use belt sanders on jets..

Regards
David
  Reply With Quote
Old 9th September 2014, 05:23 PM   #5
diyAudio Member
 
Join Date: Apr 2007
Location: Glyfada/Athens
Your only option regarding good looks is to strip, sand, prep and paint the chassis.
You can use a similar silver/grey color or experiment with something new.
The platter can be polished by a CNC shop and look as new again.
__________________
soundofvoid
  Reply With Quote
Old 9th September 2014, 06:15 PM   #6
diyAudio Member
 
Join Date: Apr 2007
Location: Glyfada/Athens
As for the glue on rubber mat... it's easy.
Soak in light oil a rug and rub it gently until it goes off.
Use the oil (or vaseline) to give back to the rubber that "like new" look.
If both are functional you can make two working examples...why toss anything away?
You can finance a perfect turntable with a very good plinth by selling the other refurbished specimen...
__________________
soundofvoid
  Reply With Quote
Old 9th September 2014, 06:24 PM   #7
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
me likee

on (spinners) topic - I just got today Lenco L75 in perfect condition , regarding motor and spindle/bearing/platter

bought it for a friend , for 40E



rubber cleaning - put them in 45C water , with mild quantity of dish washing detergent

after 10 min or so , use sponge

rinse with same temp water
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM

Last edited by Zen Mod; 9th September 2014 at 06:26 PM.
  Reply With Quote
Old 9th September 2014, 09:46 PM   #8
diyAudio Member
 
PDRCanada's Avatar
 
Join Date: Jun 2008
Very cool project, I'll be keeping an eye on this thread.
What type of plinth are you planning?
What type of arm are going to use?

I am just finishing an SP-15...I was lucky, it was in pristine shape.
The plinth I made is multi layered 1" thick...heavy as heck.

You've inspired me to start a thread....
__________________
Life in a northern town.....
  Reply With Quote
Old 9th September 2014, 11:11 PM   #9
6L6 is offline 6L6  United States
diyAudio Member
 
6L6's Avatar
 
Join Date: Oct 2010
Location: Denver, Colorado
My machinist friend was around today, so I took the platters to his shop and gave them a spin on the lathe -

I think they look quite a bit nicer!

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.
Unfortunately the platter from the 'nicer' table got dropped in the process, my fault, and got a few dings in it. This is the worst one.

I'm still probably going to go back and give the platters another round of cleaning up, I didn't bring all the compounds I wanted to try, and also ran out of time. But as they stand right now, they look much, much better than when I started.
  Reply With Quote
Old 9th September 2014, 11:13 PM   #10
SY is offline SY  United States
diyAudio Moderator
 
SY's Avatar
 
Join Date: Oct 2002
Location: Chicagoland
Blog Entries: 1
Did I mention how much I hate you?
__________________
The more you pay for it, the less inclined you are to doubt it.- George Smiley
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cheap oscilloscope for setting up a Technics SP-10 johnm Analogue Source 22 28th June 2011 07:47 PM
Technics SP-10 speed problems Stefanoo Analogue Source 3 17th August 2008 10:05 PM
Technics SP-10 MkI Start/Stop problem jgc31746 Analogue Source 2 13th April 2007 10:40 AM
Technics SP 10 Speed Problems rollinr Analogue Source 26 21st June 2004 06:44 AM
Technics SP-10 MKII pitch control peterb Analogue Source 6 28th March 2004 01:29 PM


New To Site? Need Help?

All times are GMT. The time now is 02:54 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2