sony ps-t2 speed issues - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st March 2014, 12:21 AM   #1
lexx21 is offline lexx21  United States
diyAudio Member
 
Join Date: Mar 2011
Location: North Carolina
Default sony ps-t2 speed issues

I ended up coming home from the dump today with a Sony ps-t2 turn table. It runs, but it seems to run a bit too fast.

I tried looking on vinyl engine for the manual but no luck. They have the t1, but not the t2.

I am wondering if anyone here happens to have a service manual for this table. I wouldn't mind playing with it a bit, making a separate ps/speed control unit for it. The platter seems to be somewhat "light". Far lighter than my thorens table. I can probably correct that with some strategically placed lead.

I also ended up with a garrard 440 table which seems to be frozen due to the gunky lube that they used back then. Completely clean underneath, but just "stuck". I will clean that out with some kerosene and get it running again. Also in the haul was a lafayette receiver and a hitachi tape deck. Since I am completely into tube, the receiver will likely go to a friend of mine.

Any help that you can provide would be greatly appreciated.

Thanks in advance,

John
  Reply With Quote
Old 31st March 2014, 05:09 PM   #2
Bibio is offline Bibio  Scotland
diyAudio Member
 
Bibio's Avatar
 
Join Date: Mar 2009
if it's the fully auto one with the red start touch button one of my friends had one of those from new he probably still has it as i have not seen him in a long time, lovely sounding deck :-)

i would start with servicing the trim pots or even replacing them.
  Reply With Quote
Old 1st April 2014, 12:32 AM   #3
lexx21 is offline lexx21  United States
diyAudio Member
 
Join Date: Mar 2011
Location: North Carolina
Ok, I figured it out. There is a pot on the underside of the table that controls the coarse speed. Once I adjusted that I was able to tune it in.

I setup the arm/cartridge with an Ortofon vms20e mkii and I have to say that I really like that cartridge.

The only issue that I have left to correct is that the tonearm lift doesn't go down far enough and causes the arm to skip. I'm pretty sure that I have a solution for that though.

All in all the table sounds great, especially for something that was being tossed into the dump.
  Reply With Quote
Old 3rd April 2014, 02:34 PM   #4
lexx21 is offline lexx21  United States
diyAudio Member
 
Join Date: Mar 2011
Location: North Carolina
With a dremel tool and a deburr bit, the arm lift is no longer an issue. I took off about 2mm from the top of the lift and now the arm has clearance.

Really enjoying this table. One thing that I have noticed is that the ortofon cartridge that I am using really out shines the shure v15 type iv that I have on my thorens. When I got the shure, the stylus tip snapped right off so I ended up getting a "generic" replacement. It seems muddy in the higher frequencies and I couldn't quite put my finger on the problem until now.

Has anyone here tried the Jico replacement stylus for the v15? I wanted to get some feedback on them before I go and dump $180 on a new stylus.
  Reply With Quote
Old 13th April 2014, 11:04 PM   #5
diyAudio Member
 
Join Date: Apr 2014
Hi. I was wondering if you ever found a service manual for your ps-t2? I have the same model, picked it up at a garage sale. It's in great shape, but I'd love to find the manual myself. You might know this, but I'm going to be transporting the turntable and I'd like to lock the table. I'm not sure how to go about doing that without the manual. Any ideas? Thanks for the tip on the Ortofon cartridge also, I was wondering how to select a new one and was searching around for any info. Your first-hand experience is a big help. Thanks.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oracle Delphi MK III speed issues...help kilohertz Analogue Source 47 4th March 2014 09:49 PM
Sony tts 8000 speed problem exurbia Analogue Source 2 8th February 2010 12:17 AM
DHT and speed issues mahleriana Tubes / Valves 54 14th January 2009 07:56 PM
Sony PS-X50 direct drive speed problem PTSOUNDLAB Analogue Source 3 26th August 2007 07:24 AM
Designing a motor speed controller/PS - querying motors GUILHERME Analogue Source 11 3rd November 2002 10:09 PM


New To Site? Need Help?

All times are GMT. The time now is 04:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2