Oracle Delphi - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd May 2013, 09:55 AM   #1
diyAudio Member
 
Join Date: Sep 2012
Location: Auckland, New Zealand
Default Oracle Delphi

I have just become the proud owner of an Oracle Delphi Mkii.
It was bought minus a tonearm but I have installed a Sumiko MMT with a Denon DL160. A whole afternoon was spent assembling this beautiful piece of engineering and adjusting the suspension for a perfect vertical bounce.
It sounds as good as it looks and performs perfectly.
The only minor issue is the 45 speed does not operate when the switch is pressed, it continues to play at 33. I don't actually have any 45 records but would like everything to work correctly. Underneath the motor is a little circuit board with a small relay on it that I suspect may be the culprit but don't want to start poking around without some information first.
Does anyone have first hand experience with this problem or know where I can get a wiring diagram ?
I have emailed Oracle in Canada but so far no response.
Cheers
Graham.
  Reply With Quote
Old 26th May 2013, 02:28 AM   #2
diyAudio Member
 
Join Date: Sep 2012
Location: Auckland, New Zealand
Looks like I'm on my own here.
I've had no response from Oracle and nobody on this forum.
I'm pretty sure it is the relay as it doesn't seem to respond to the switch, but I'm not keen to start delving blind.
Graham.
  Reply With Quote
Old 28th May 2013, 01:53 AM   #3
diyAudio Member
 
Join Date: Feb 2010
Default speed control pots?

These have a reputation for motor's failing - have never actually run into this - but did encounter dirty speed adjustments pots - these could get a "dead" spot and the motor won't turn at all when adjusted to that point. I can't think of how this could lead to the thing turning at 33 when 45 is selected - hmm - any chance that the 45 speed pot can be turned far enough to actually run at 33 /1/3 RPM ?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oracle Delphi MK.2 Upgrades GeeVee Analogue Source 3 19th November 2009 10:14 AM
New Oracle Delphi owner questions summilux Analogue Source 4 28th April 2009 02:33 PM
oracle delphi maintenance kit Daniel-A Analogue Source 0 6th March 2005 11:41 PM
Oracle Delphi( Best arm for this dec) croft Analogue Source 32 29th June 2004 05:04 AM
Oracle Delphi motor can't achieve right speed... m.parigi Analogue Source 12 10th December 2003 06:49 PM


New To Site? Need Help?

All times are GMT. The time now is 01:11 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2