Oracle Delphi MK IV speed problem - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th November 2003, 08:05 AM   #1
diyAudio Member
 
Join Date: Nov 2003
Location: Paris
Question Oracle Delphi MK IV speed problem

Hello, I am new here. Maybe someone have an answer for this problem I have. I have a very nice Oracle Delphi MK IV. Not upgraded. I am having problems with the speed. I can't get it to go at the right speed. It is too slow. Using the adjustments do change the speed but not up to the correct one. Any ideas? Maybe I need a new motor. Or the upgrade.

Many thanks,

Eric
  Reply With Quote
Old 26th November 2003, 09:02 PM   #2
diyAudio Member
 
Audiofanatic's Avatar
 
Join Date: Oct 2002
Location: The Netherlands, Utrecht
Default Oracle Delphi

Hi Eric Sisi,


Check your Power supply (Wall wart if you have one) voltage.
If it varies to much a few volts than try a otherone.

Make shure it's AC or if you have a DC PSU check polarity.

All the best.


Audiofanatic
__________________
Be nice to animals.
  Reply With Quote
Old 2nd December 2003, 03:50 PM   #3
sreten is offline sreten  United Kingdom
diyAudio Member
 
Join Date: Nov 2003
Location: Brighton UK
Describe the problem in more detail, for example history,
and give some more info about the motor and how the
speed is adjusted.

May be able to help, or make some suggestions, /sreten.
  Reply With Quote
Old 5th December 2003, 12:38 PM   #4
diyAudio Member
 
Join Date: Jan 2002
Location: Italy
Check out this thread: I used to have the same problem!

http://www.diyaudio.com/forums/showt...5941#post55941

Hope this helps!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oracle Delphi MK III speed issues...help kilohertz Analogue Source 48 25th September 2014 06:21 AM
New Oracle Delphi owner questions summilux Analogue Source 4 28th April 2009 03:33 PM
oracle delphi maintenance kit Daniel-A Analogue Source 0 7th March 2005 12:41 AM
Oracle Delphi( Best arm for this dec) croft Analogue Source 32 29th June 2004 06:04 AM
Oracle Delphi motor can't achieve right speed... m.parigi Analogue Source 12 10th December 2003 07:49 PM


New To Site? Need Help?

All times are GMT. The time now is 01:36 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2