Sansui T-550SW circuit - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th December 2012, 04:57 AM   #1
Roushon is offline Roushon  India
diyAudio Member
 
Join Date: Sep 2004
Location: Mumbai (Bombay)
Default Sansui T-550SW circuit

I just got an used Sansui T-550SW tuner. The seller
claimed it was in perfect working condition. On first power
ON the surround dial light and also the light around the
tuning knob went ON for a few seconds and then OFF for
ever. On connecting the amp and antenna although it is
showing full signal, but no output, just dead. Tried all
possible way. But it is just not talking...Does anyone
have a circuit or a manual for this tuner? Or any
suggestion! Will open it after listening to experts here.


Thanks and regards
Roushon
__________________
S. Roushon
  Reply With Quote
Old 12th December 2012, 12:10 PM   #2
Roushon is offline Roushon  India
diyAudio Member
 
Join Date: Sep 2004
Location: Mumbai (Bombay)
This is an analogue tuner...almost an antique piece...the seller claimed it is in pristine condition...so I am hoping the problem is not very serious, some
minor thing happened during shipping...
__________________
S. Roushon
  Reply With Quote
Old 12th December 2012, 12:43 PM   #3
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Your going to have to get the top off and have a measure. I would just look at why the lights have failed and see where it leads back too. The bulbs not lit are a definite easy fault to trace. Cpuld be a dry joint, loose fuse... anything but it sounds easily fixable.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 23rd December 2012, 12:56 PM   #4
Roushon is offline Roushon  India
diyAudio Member
 
Join Date: Sep 2004
Location: Mumbai (Bombay)
Quote:
Originally Posted by Mooly View Post
Your going to have to get the top off and have a measure. I would just look at why the lights have failed and see where it leads back too. The bulbs not lit are a definite easy fault to trace. Cpuld be a dry joint, loose fuse... anything but it sounds easily fixable.
Thanks Mooly for your wisdom. It was all very hard work
as I never opened such an old electronics. Also was
not sure where to hit and at the same time was afraid that
I may damage some good part of the circuit. But
surprisingly the problem was very trivial: the RCA socket
points were disconnected from the track because of
prolong use I guess. Finally the tuner is fully alive and
kicking. Replaced the dial light also (finding the dial
light in Mumbai was also another adventure). It was a
satisfaction I will remember...

Regards
Roushon.
__________________
S. Roushon
  Reply With Quote
Old 23rd December 2012, 01:01 PM   #5
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Thanks for the update and well done with the repair
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sansui 9090 IC equivalent circuit allears Solid State 3 26th October 2012 09:40 AM
Sansui help please? cross reference Solid State 22 4th September 2012 07:21 AM
With painted a circuit, STI(2SK182E) pipe of the SRPP circuit, is feasible? lgqliu Solid State 2 25th February 2012 07:07 PM
Trouble with speaker protection circuit (Randy Slone's circuit) whalefat Solid State 3 13th April 2005 11:13 AM


New To Site? Need Help?

All times are GMT. The time now is 10:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2