Extremely noisy DC (Phono Stage PSU) - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd September 2012, 09:56 AM   #1
diyAudio Member
 
Join Date: Mar 2002
Location: n/a
Default Extremely noisy DC (Phono Stage PSU)

Hey all.

I'm currently trouble shooting noise problems on my tube phono stage (each channel contains two triode strapped C3gs, loaded by a CCS). The power supply is a schottky diode rectified with an RCRCRC filter (R = 270ohm, c = 50uF, except the last one, which is 100uF).
The power supply is in a seperate enclosure, and via the umbillical wire, I'm carrying B+, 0V, earth, and two 6.3VAC heater supplies (so 4 wires there). Each wire is tightly twisted with its opposing pole, and then covered in a shield (connected to earth).
Anyway, when I connected the DC to a scope (the probe was on B+, the reference was the 0V line), the output looked like the attached file (this was taken from the phono chassis, not the PSU chassis).

Any clues ? If I zoom in, there is ripple, but it looks modulated on some really low frequency noise.
Attached Images
File Type: jpg NewFile0.jpg (63.9 KB, 359 views)
  Reply With Quote
Old 3rd September 2012, 10:51 AM   #2
diyAudio Member
 
Join Date: Apr 2012
Location: Kiel, Germany
Hello,
is that 2s/DIV on your scope? That would mean you have a supply that varies rather than a noisy one.
Is the varaition larger close to the rectifier or close to the amplifier? Meaning: do we deal with a variation in mains or in load?
Your load should be a very constant one as it uses a CCS.
Have you compared the time constant of your filter chain to the "slew rate" of the voltage changes?
  Reply With Quote
Old 3rd September 2012, 11:14 PM   #3
diyAudio Member
 
Join Date: Mar 2002
Location: n/a
Well I took a trace of the PSU unloaded (close to the rectifier), and it looks the same (I also added a zoomed in trace, showing the actual ripple)
And yes, that's a 2s div.

My next question was going to be is if this is what motorboating looks like ?

And what do you mean by time constant of the chain, to slew rate of change ?
Attached Images
File Type: jpg NewFile22.jpg (47.0 KB, 304 views)
File Type: jpg NewFile15.jpg (46.4 KB, 298 views)
  Reply With Quote
Old 3rd September 2012, 11:29 PM   #4
diyAudio Member
 
danielwritesbac's Avatar
 
Join Date: Nov 2007
Quote:
Originally Posted by lordvader View Post
The power supply is in a seperate enclosure, and via the umbillical wire, I'm carrying B+, 0V, earth, and two 6.3VAC heater supplies (so 4 wires there). Each wire is tightly twisted with its opposing pole, and then covered in a shield (connected to earth).
I notice two things.
Umbilical = big inductive resistor, so do you have at least 220u right next to the tubes (aka got caps in the amp enclosure)? I ask because, with inductance disabling the caps at HF, your amp has no defense against the unfiltered AC that is wrapped up with your DC power cable. Same flaw exists in most USB sound modules--dirty power in the same cable as signal line.

Perhaps, reg the heater supplies (clean DC heater?) within the power box and put some power caps in the amp box. Maybe that will get rid of the HF blast. I do not know.
__________________
Tools, Models & Software for DIYClipNipper boostLM1875 TurboPowerful TDA7293 kitTDA7294 pt2pt ♦ My post has opinion.
  Reply With Quote
Old 3rd September 2012, 11:59 PM   #5
diyAudio Member
 
Join Date: Mar 2002
Location: n/a
I don't have any filter caps in the phono chassis, so that's something I'm planning on trying.
I'm also thinking about a filter cap next to each CCS (as there is a bit of distance between the B+ lug, and the CCSs).

The above images though (yellow traces) are of the PSU completely unloaded (well, only loaded by a 100K bleeder, and a 100K|33K voltage divider to raise the heaters).
  Reply With Quote
Old 4th September 2012, 12:52 AM   #6
kevinkr is offline kevinkr  United States
diyAudio Moderator
 
kevinkr's Avatar
 
Join Date: Sep 2004
Location: Boston, Massachusetts
Blog Entries: 6
Since this is trouble shooting a noisy phono stage it seems to me that this might better go in the analog source forum.. I'll retitle to reflect that it is a phono stage PSU..

I have a number of thoughts which I will post separately.
__________________
"Extraordinary claims require extraordinary evidence." - Carl Sagan
  Reply With Quote
Old 4th September 2012, 01:02 AM   #7
kevinkr is offline kevinkr  United States
diyAudio Moderator
 
kevinkr's Avatar
 
Join Date: Sep 2004
Location: Boston, Massachusetts
Blog Entries: 6
I suspect the low frequency wander is probably slow cyclical variations in your mains voltage.. I see the same thing here...

You definitely need local decoupling at the CCS, perhaps even a few uF would be enough to assure that they are not misbehaving..

I use DC to heat the filaments in phono stages as this is just one less source of noise to couple into the audio circuitry, and more to the point variations in heater voltage will cause LF wander in the output of your phono stage.

Please post the design of both PSU and phono stage and we'll help you get it sorted. (See my Muscovite thread for the extremes I went to with the power supply - of course I used a cascode front end with zip for PSRR.)
__________________
"Extraordinary claims require extraordinary evidence." - Carl Sagan
  Reply With Quote
Old 4th September 2012, 01:17 AM   #8
diyAudio Member
 
Join Date: Mar 2002
Location: n/a
I'm attaching the PSU schematic, and phono schematic (note, that rather than 210 for B+, B+ it about 250V. The CCS drops the voltage to about 180V). The grid stoppers are also 1K rather than 120.
Also, the diodes are schottky diodes, so there are no snubbers on them.

The single B+ powers both channels, with each stage having its own star ground (ie, the first tubes share a star), and the stars then joining up to a single 0V point.

To decouple the CCS, would 10uF suffice ?

I'm thinking about DC for the filaments, but as they're already 6.3VAC, I don't think I can get 6.3VDC from them (well, get a nice 6.3VDC anyway).

Also, thanks for everyones input so far ! I'm been DIY'ing for a while, but this is my first "sensitive" project
Attached Images
File Type: jpg C3g_phono.jpg (80.0 KB, 296 views)
File Type: jpg c3g_psu.jpg (24.4 KB, 294 views)
  Reply With Quote
Old 4th September 2012, 01:54 AM   #9
diyAudio Member
 
danielwritesbac's Avatar
 
Join Date: Nov 2007
Quote:
Originally Posted by lordvader View Post
To decouple the CCS, would 10uF suffice?
The inductance of the cable and the tracks does what any inductor will do and that's disable the remote caps from being useful at higher frequencies. The amount of patchwork needed relates to this, but I don't know the exact amount, since it is layout specific. However, the device is highly sensitive, so the most effective approach could be tuning it by ear (it is, after all, a device made to please an ear). That works as long as you pick the right spot to apply the fix. Perhaps someone smarter than me could name the correct value or plausible range of values for it?
Quote:
Originally Posted by lordvader View Post
I'm thinking about DC for the filaments, but as they're already 6.3VAC, I don't think I can get 6.3VDC from them (well, get a nice 6.3VDC anyway).
Ordinary prefab bridge rectifier and caps will up the voltage to about 9.2vdc and then a regulator can work. You might need a schottky bridge rectifier (high amperage low voltage schottky specs are lowest loss) and a low dropout regulator though since I don't know how much rail droop is present.
__________________
Tools, Models & Software for DIYClipNipper boostLM1875 TurboPowerful TDA7293 kitTDA7294 pt2pt ♦ My post has opinion.
  Reply With Quote
Old 4th September 2012, 02:06 AM   #10
diyAudio Member
 
Join Date: Mar 2002
Location: n/a
I am planning on adding a 100 or 220 uF capacitor in the phono chassis (there are currently 0.1 and 0.01 uF bypass caps there).

I'll have a go at DC rectifing when I get a chance, but there are about a million options out there when it comes to regulation !
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DH-101 with a noisy phono stage grtyvr Analogue Source 27 2nd February 2012 05:57 PM
Help - noisy phono stage ianc13 Tubes / Valves 11 8th July 2009 05:18 PM
Noisy PSU? pftrvlr Tubes / Valves 16 2nd July 2007 06:26 AM
Should I replace Scott 222C phono stage with Claret phono stage? Bing Yang Analogue Source 0 22nd August 2005 06:41 AM
How can i use a noisy PSU ? Garbz Solid State 5 3rd January 2004 12:15 AM


New To Site? Need Help?

All times are GMT. The time now is 03:10 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2