Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Armstrong 523 tuner problem
Armstrong 523 tuner problem
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st December 2009, 01:40 PM   #1
stevecole is offline stevecole  United Kingdom
diyAudio Member
 
Join Date: Apr 2008
Default Armstrong 523 tuner problem

I have been trying to repair an Armstrong 523 FM/AM tuner for a friend. The tuner is at least 40 years old. Mono reception is fine, but in Stereo mode the pilot light illuminates, implying that a stereo signal is present, but the audio remains in mono, with a faint 'chuffing' noise in the background. This noise stops when mono mode is selected.

Compared with modern tuners using IC's, the decoder circuit, which lives on a separate PCB, seems very simple, with only 4 or 5 transistors. I have tested every component and nothing appears to have failed. The owner of the tuner has suggested that the decoder is based on a Mullard standard circuit, but I have been unable to unearth either this or a diagram for the tuner on the web. Can anyone offer any suggestions?
  Reply With Quote

Reply


Armstrong 523 tuner problemHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sont STR-6800SD Tuner Problem zedrider Solid State 1 18th October 2007 04:45 AM
Yamaha RX-V490.. Tuner problem tharakag Solid State 7 5th September 2007 09:47 PM
Problem with Sony tuner memory Lourens Analogue Source 8 18th July 2005 07:45 PM
NAD 7020, problem with tuner++ (centering). hanspd Solid State 0 26th January 2004 02:37 PM
DIY FM Tuner - what's the problem? jackinnj Solid State 3 26th April 2002 09:49 PM


New To Site? Need Help?

All times are GMT. The time now is 04:00 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki