Valve Itch phono - Page 66 - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th May 2012, 09:40 PM   #651
RevMen is offline RevMen  United States
diyAudio Member
 
RevMen's Avatar
 
Join Date: Feb 2011
Location: Austin, TX
Quote:
Originally Posted by Salas View Post
Do you use two separate chassis as in the above diagram?
One chassis. Power supply pcbs are mounted to the bottom plate, audio circuit is point to point on the top.
  Reply With Quote
Old 28th May 2012, 01:06 AM   #652
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Since its difficult to pin point grounding troubles in differentiated builds by wild guessing from afar, better use yin yang diodes safe ground lift scheme to chassis but make sure you got the mains ground lug connected to chassis.
  Reply With Quote
Old 28th May 2012, 03:48 AM   #653
RevMen is offline RevMen  United States
diyAudio Member
 
RevMen's Avatar
 
Join Date: Feb 2011
Location: Austin, TX
I will try that, thanks.
  Reply With Quote
Old 1st June 2012, 06:12 PM   #654
webby is offline webby  United Kingdom
diyAudio Member
 
Join Date: Jul 2004
Location: england
Hi All,

Can anyone help?
I lost interest in this project due to my daughter being born, and my group buy caps getting lost in the post.
Now I have caught up on some sleep, I would like to have another go at building this project.

Does anyone have any components left over I can buy?
Finger crosses, one of you has a complete build / kit they could sell me.

I hope everyone is well.
All the best
Ian
  Reply With Quote
Old 2nd June 2012, 11:35 AM   #655
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
Congrats Ian, finally I don't used my RIAA caps (because don't start the Itch): if you want them only by registered mail, please let me know?

Cheers
Felipe
  Reply With Quote
Old 2nd June 2012, 01:44 PM   #656
webby is offline webby  United Kingdom
diyAudio Member
 
Join Date: Jul 2004
Location: england
Many Thanks Felipe!
registered mail does sound sensible.
PM me the cost and I will PPal you.

If anyone else has any other parts they would sell, please let me know.
I'm Itching to build this project.

Cheers
Ian
  Reply With Quote
Old 2nd June 2012, 01:48 PM   #657
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
Ian what's the rest or parts that are you looking for?

Cheers
Felipe
  Reply With Quote
Old 2nd June 2012, 04:25 PM   #658
webby is offline webby  United Kingdom
diyAudio Member
 
Join Date: Jul 2004
Location: england
I am looking for all the components, including valves, and transformer.
And to populate the SSHV & Heater pcb's I bought from you.

Many Thanks
Ian
  Reply With Quote
Old 2nd June 2012, 06:59 PM   #659
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
Ian better to follow by PM or email, I'm sorry Salas for a lot OT
  Reply With Quote
Old 3rd June 2012, 05:20 PM   #660
RevMen is offline RevMen  United States
diyAudio Member
 
RevMen's Avatar
 
Join Date: Feb 2011
Location: Austin, TX
Quote:
Originally Posted by Salas View Post
better use yin yang diodes safe ground lift scheme to chassis but make sure you got the mains ground lug connected to chassis.
I separated the circuit from the chassis using the yin-yang diodes but there was no difference. R1 burns up immediately any time the circuit is attached to the chassis. I removed all of my connecting wires in the power supply and replaced them, just to be sure I didn't have any mistakes in the connections.

I've just about reached the giving up point on this project. The whole circuit works fine as long as it's completely floating. As soon as there's any kind of connection to chassis R1 burns up. I just don't have enough knowledge to solve this problem. I don't know what to look for or what to test.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Got the build itch again. 80w kt88 itsmejto Tubes / Valves 44 26th September 2008 11:49 PM
valve phono stage wanted for mc brobarrie Swap Meet 1 13th August 2007 08:17 PM
Basic DIY Valve Phono Stage matthew2456 Tubes / Valves 5 29th March 2007 04:11 AM
Phono pre, valve or jfet lndm Analogue Source 7 4th April 2006 02:11 PM
phono preamp design for c3m postie valve fergs1 Tubes / Valves 1 29th May 2005 02:12 PM


New To Site? Need Help?

All times are GMT. The time now is 01:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2