only right sound from my Technics SL-1200 - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th February 2009, 06:18 PM   #1
diyAudio Member
 
Join Date: Feb 2009
Default only right sound from my Technics SL-1200

hello, i have a problem since 2 days, the sound of my turntable is only on the right speaker. the left doesn t work. it s not my speakers or mixer cause my 2nd MK2 is ok. i inverted the 2 RCA and that changes nothing except i have the left pseaker only instead of the right speakers only. can i open my MK2 and check what s the problem ? is anyone having a clue about what s happening.. probably a disconnet wire inside...
  Reply With Quote
Old 11th February 2009, 11:24 PM   #2
Salas is online now Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
See to work your headshell to arm contacts a bit. Get the shell off the arm, tease the contact points in and out with some toothpick or thin screwdriver. They can be stuck.
  Reply With Quote
Old 11th February 2009, 11:33 PM   #3
Salas is online now Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
P.S. I mean the ones in the arm. The ones on the shell don't play, but you can look if they are clean given the opportunity.
  Reply With Quote
Old 12th February 2009, 10:59 AM   #4
burbeck is offline burbeck  United Kingdom
diyAudio Member
 
Join Date: Aug 2004
Location: Ratae Coritanorum
hi
the phono leads on these decks fail as the inner conductor is very fragil, they usualy break in or near the phono plugs or at the arm base.

all 4 need to be tested for contnuity

the break could be in the very thin wires in the tone arm but less common.

to check the phono cable the arm base and the whole rubber bottom of the turntable needs to be removed to gain access to the other end of phono leads, then measure continuity on each connection there are 4

be careful not to damage tone arm when removing base

good luck
__________________
regards
bob
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Technics 1200 PS and Tonearm mods recca Analogue Source 19 11th September 2010 08:39 PM
Technics Sl 1200 bearing nimbus24 Analogue Source 10 22nd July 2009 11:27 AM
Technics 1200 tonearm troubleshooting tuffstuff Analogue Source 6 4th June 2009 06:54 AM
Technics SL-P 1200 NoBit Digital Source 0 18th April 2008 11:28 AM
technics 1200 pitch correction megatron Analogue Source 4 23rd February 2004 07:11 AM


New To Site? Need Help?

All times are GMT. The time now is 07:01 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2