My Revox B790 has blown its fuse - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th September 2008, 08:41 PM   #1
csrote is offline csrote  United States
diyAudio Member
 
Join Date: Jun 2008
Default My Revox B790 has blown its fuse

Fuse is 400ma @ 120v or 200ma @ 240v. It is not available at Radio Shack (closest is 500ma@240v) so I will need to do an actual parts order from a major parts house (was going to do any way for other projects.)

I have the service manual.

A blown fuse implies power supply problems. Any tips on trouble shooting the PS when I finally get the proper fuse?

Thnx for all help,
Cliff
  Reply With Quote
Old 18th September 2008, 02:02 PM   #2
diyAudio Member
 
Join Date: Sep 2004
Location: virginia
In the US you want the 400ma 120V fuse. Home Depot has some of those European fuses, so you might find it there in the electrial parts. I have seen fuses open for no apparent reason except old age.

The 500ma 250V fuse will work, but the current rating is 25% too high.

Regards,
Ray
  Reply With Quote
Old 18th September 2008, 03:17 PM   #3
SaSi is offline SaSi  Greece
diyAudio Member
 
Join Date: May 2008
IIRC, the fuse in the Revox TTs is a slow blow one. I've replaced the original one with a slightly overrated quick blow one, but overrated by 100mA only.

One of the most simple reasons why the fuse might blow is that the decoupling capacitor that is soldered on the mini PCB where all the AC power cables concentrate is short. Inspect it closely and you might find it has turn black or even broken at one side.

You could also remove that PCB from the base and check the resistance across the capacitor's leads. If it is 0, then it is probably dead.
  Reply With Quote
Old 18th September 2008, 05:49 PM   #4
diyAudio Member
 
Steerpike's Avatar
 
Join Date: Jan 2006
Location: Johannesburg, South Africa
Since it's a ReVox, my bet is one of the three large electrolytic capacitors on the power supply PCB has gone short circuit.
Those Frako ones are almost guaranteed to go short after 30 years, so you might want to replace them anyway while you're ordering parts.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
amp blown fuse = output offset ? AndrewT Solid State 42 13th November 2014 07:45 AM
Repairing Class A/AB amp with Blown Fuse excetara2 Analog Line Level 5 8th March 2009 10:34 AM
Please help: no sound and blown fuse spendorspain Tubes / Valves 6 11th December 2008 02:48 PM
ETI480 blown fuse... bezel6 Solid State 1 30th November 2005 12:25 AM
Blown fuse!!! StalfoS Chip Amps 13 4th June 2005 01:10 PM


New To Site? Need Help?

All times are GMT. The time now is 08:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2