Simplistic NJFET RIAA - Page 480 - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th September 2010, 03:22 PM   #4791
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
Quote:
Originally Posted by massimo View Post
3 dB, as Salas pointed out. Unless yoy would like to "copy" Accupahse in its lastest C27 phono stage (>10.000 €) where is using 16 (sixteen!) BJTs in parallel to further reduce noise (well, actually 32, as it's a symmetric topology)
I'm not going balanced to have more gain, I'm going balanced to avoid ground loops & avoid esoterics wires.

I will use only five 2SK170BL per four channels = 20 pcs (1st stage 2 parallel & 2nd stage 2 parallel & the other one with LEDs string) as Salas suggested by pm, the great new is that with the new schematic only will need 2.2uF like output cap

Also I have in mind to make 4 regs V1.2 one for each channel, of course 4 Tx one for each channel.
  Reply With Quote
Old 10th September 2010, 04:57 PM   #4792
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Quote:
Originally Posted by RCruz View Post
I read that "Linearity does not nessecerely improve, but you might end up with less low order, and more high order distortion."

Do you agree with this quote ?
For what you read that? Cascode, or paralleling? This phono shows more 2ndH than 3rd as a whole in all configurations measured till now BTW.
  Reply With Quote
Old 10th September 2010, 05:03 PM   #4793
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Quote:
Originally Posted by SGregory View Post
Quick Update. Found that Q1 was blown on second board. (replaced). I also verified that LED is installed correctly. Have not retested yet and will do this weekend, after rechecking all joints. I also want to reverify that BJT/jfet orientations are correct(again).
Mostly orientations tend to got wrong, or some joint missing, check those well.
  Reply With Quote
Old 10th September 2010, 08:20 PM   #4794
diyAudio Member
 
Join Date: Apr 2003
Location: Southern Tier NY
How about substituting a 2N5459 for Q6? Somehow during the pcb design I did that. Should be a 2N5457. Doesn't explain why the LED doesn't light up however.
__________________
Living Life Doing the Waltz in 4/4 meter.
  Reply With Quote
Old 10th September 2010, 08:24 PM   #4795
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Can change the OLG and upset compensation. 2N5457 or BF245A. Trim down the 5459 to 2.5mA with a resistor between S and its now connection point is a fast test. Are the BJTs correctly oriented, those cascoded above the LED and the Mosfet controlling BJT too? Burning the CCS Mosfet or R1 smells its not controlled.

P.S. I have had some Riaa curves still in the FFT memory banks and centered them like in the Ref Spice graph. They fall so near, and frequency bins undulations or any card correction file and visual precision makes it hard to know if its dead on or just very slightly off. It falls in measurement system calibration and subjective territory given the cart and rest of system to play with C3 or not. Its our LCR DVMs that can play, everything. But I would not tune heavier than 100-150pF tolerance subjectively.
  Reply With Quote
Old 10th September 2010, 08:51 PM   #4796
diyAudio Member
 
Join Date: Apr 2003
Location: Southern Tier NY
Orientation looks correct on Q9, Q2, and Q8. I did find an ultimate oops. During the build I found a tube with matched IRFP9240 written on them. Had a sticker with respective Vgs on the front from the excersize several years ago. So I used them.
Got curious a few minutes ago and pulled the sticker off to reveal that they are IRFP244's. I have now replaced them with IRFP9140's and will take a few minutes off to pick-up my kids from football practice and regain my pride.

Must remind myself that ASSUME is an acronym.!
__________________
Living Life Doing the Waltz in 4/4 meter.
  Reply With Quote
Old 10th September 2010, 08:54 PM   #4797
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Having used NMosfets instead of PMosfets is a major ooops indeed.
  Reply With Quote
Old 10th September 2010, 09:15 PM   #4798
diyAudio Member
 
Join Date: Apr 2003
Location: Southern Tier NY
Please don't tell anyone;-)
__________________
Living Life Doing the Waltz in 4/4 meter.
  Reply With Quote
Old 10th September 2010, 09:51 PM   #4799
diyAudio Member
 
Join Date: Apr 2003
Location: Southern Tier NY
Pleas confirm the following. On the IRF9610 and IRFP9240, the pinout is as follows.
Looking at the device from the front, pins 1, 2, 3 from left to right. Pin 1 = Gate, Pin 2 = Drain, Pin 3 = Source.

Is that correct. I have verified the rest of the BJT's and JFets to be correct.

What I have now is no current passing what so ever. LED is out. Drain on Q1 is at 0V while S is at 60V. Gate is 0.15V. E and B of Q7 are at 60V while C is at 0.15V,
That is way above the max allowable Vgs for Q1 so I will assume it is blown. Q7 is probably also toast as it has a Vce of 45V
__________________
Living Life Doing the Waltz in 4/4 meter.

Last edited by SGregory; 10th September 2010 at 10:07 PM.
  Reply With Quote
Old 10th September 2010, 10:17 PM   #4800
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Assuming your connections and orientations are OK, some things may have blown in your previous NMos power up. I would change the error amp BJT and 2SK170 first. Mosfets don't blow up in that circuit so easily. But in such a scenario you may have well given it a general haircut. The LED would need some Vin-Vout to come up. Well above 0 Vo. Also did you start your trimmer half way? Are the sense and force all connected across the dummy?
Attached Images
File Type: gif 220.gif (5.2 KB, 134 views)
File Type: gif 247.gif (7.9 KB, 129 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 04:06 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2