Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Linn Valhalla - strange fault
Linn Valhalla - strange fault
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th August 2008, 09:50 AM   #1
GlidingDutchman is offline GlidingDutchman  South Africa
diyAudio Member
 
Join Date: Nov 2007
Default Linn Valhalla - strange fault

I use a stock Linn Valhalla PSU with my custom turntable. It is mounted in a stainless steel case and fitted with a mains switch (to turn it off when not in use).

It has worked great for over 8 months now but lately it has developed a strange fault.

When I turn on the mains power its starts up without me pressing the "operate" button (never done this before!).

The machine runs great but this fault bothers me. Any ideas on how to sort this out?

Thank you

GD
  Reply With Quote
Old 8th August 2008, 05:28 PM   #2
kevinkr is offline kevinkr  United States
diyAudio Moderator
 
kevinkr's Avatar
 
Join Date: Sep 2004
Location: Boston, Massachusetts
Linn Valhalla - strange fault
Schematic to start would help.. Bad switch?
__________________
"To argue with a person who has renounced the use of reason is like administering medicine to the dead." - Thomas Paine
  Reply With Quote
Old 8th August 2008, 06:05 PM   #3
analog_sa is offline analog_sa  Europe
diyAudio Member
 
analog_sa's Avatar
 
Join Date: Aug 2002
Location: Cascais
The power switch controls directly a 4013 D-type flip flop. It seems like the FF gets into the wrong state on power on. One way for this to happen is PS noise (the reset pin is permanently grounded). The obvious suspect is a dry C3.
  Reply With Quote
Old 9th August 2008, 07:05 AM   #4
GlidingDutchman is offline GlidingDutchman  South Africa
diyAudio Member
 
Join Date: Nov 2007
Thank you guys.

I have the schematic and I'll check the C3 cap.

Switch is A-OKAY.

GD
  Reply With Quote

Reply


Linn Valhalla - strange faultHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with linn Valhalla repair ericpeters Analogue Source 38 25th January 2017 02:55 AM
Linn Valhalla 6072a Analogue Source 8 21st December 2016 09:32 AM
Very strange fault (CD-player) jitter Digital Source 37 4th December 2012 05:43 PM
Linn Valhalla - Value of R40 and D3 SPWONG Analogue Source 1 20th January 2008 12:01 AM


New To Site? Need Help?

All times are GMT. The time now is 08:30 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki