diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Analogue Source (http://www.diyaudio.com/forums/analogue-source/)
-   -   Empire 208 tonearm wiring question (http://www.diyaudio.com/forums/analogue-source/121165-empire-208-tonearm-wiring-question.html)

FoleyF 11th April 2008 06:51 PM

Empire 208 tonearm wiring question
 
Hi Everyone, been lurking for a few years and now have my first post.

I have an old empire 208 turntable with the stock tonearm from the 60's. Right now the turntable is not working as the wiring in the tonearm is not connected to any audio cables. In its current state, the tonearm is connected to the table and all of the wires are coming out of the bottom as they should be. When I initially purchased the table, the wires were connected to some sort of board and then audio cables came off of that board so I could connect it to my stereo system.

Can anyone tell me how I can connect these wires to the proper type of phono cables? I no longer have the board that the tonearm wires were originally connected to, nor do I have the phono cables that run to the stereo system.....I just have a great turntable with all of the wires hanging from the tonearm.

Any help would be appreciated.....also, if I need parts, please let me know where you think I could get them.

Thanks,

Foley


All times are GMT. The time now is 05:43 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2