Technics 1210 Mk5 Problem - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st October 2007, 03:08 AM   #1
qwaszx is offline qwaszx  India
diyAudio Member
 
Join Date: Oct 2007
Default Technics 1210 Mk5 Problem

Hi all ,

Just got pair of Technics 1210 2 months back.starting to face problems in one set.

The problem when ever i take the pitch between -7 to -8 the platter vobles i am able to hear a tear sound this continues till i switch it off and on it again after some time it starts the platter start moving again.

I have a Speaker system beside my turntable is it beacuse of strong magnetic field my fader is dying or is it some thing else.

I am really tensed since i huge amount invested in this its really starting to pinch.
  Reply With Quote
Old 31st October 2007, 03:28 AM   #2
diyAudio Member
 
Boris_The_Blade's Avatar
 
Join Date: Mar 2007
I had really erratic problems with my 1510 until I traced it down to dirty control potentiometers and switches. Give those a really good cleaning and see what happens. Lemme know cause I'm curious.

good luck
  Reply With Quote
Old 31st October 2007, 03:29 AM   #3
diyAudio Member
 
ashok's Avatar
 
Join Date: Jun 2002
Location: 3RS
Could be that the pitch control slider is dirty . You might need to spray a contact cleaner into it to determine that. Better to use one of of those contact cleaners from CRC that leaves no residue or oily deposit. WD40 is something I would not use.
Spray some contact cleaner and move the slider up a down a few times. Do it a few times to ensure the slider is clean.
Cheers.
__________________
AM
  Reply With Quote
Old 31st October 2007, 05:19 AM   #4
diyAudio Member
 
ashok's Avatar
 
Join Date: Jun 2002
Location: 3RS
Also check
http://www.vinylengine.com/library_m..._model=SL-1210
__________________
AM
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Technics SL1200 / 1210 Speed Fluctuation Problem rob110101010001 Analogue Source 5 1st September 2014 12:35 AM
Technics 1210 DC Power Problem!! tdiman Analogue Source 8 27th March 2011 01:53 PM
Problem in pitch TECHNICS SL 1210 Willian Pires Analogue Source 4 7th February 2008 03:51 PM
Technics 1210 problem matt J Analogue Source 5 19th April 2007 09:25 PM
technics 1210 problem tdiman Analogue Source 3 25th November 2005 03:50 PM


New To Site? Need Help?

All times are GMT. The time now is 08:27 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2