diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Analogue Source (http://www.diyaudio.com/forums/analogue-source/)
-   -   Technics 1210 Mk5 Problem (http://www.diyaudio.com/forums/analogue-source/111030-technics-1210-mk5-problem.html)

qwaszx 31st October 2007 03:08 AM

Technics 1210 Mk5 Problem
 
Hi all ,

Just got pair of Technics 1210 2 months back.starting to face problems in one set.

The problem when ever i take the pitch between -7 to -8 the platter vobles i am able to hear a tear sound this continues till i switch it off and on it again after some time it starts the platter start moving again.

I have a Speaker system beside my turntable is it beacuse of strong magnetic field my fader is dying or is it some thing else.

I am really tensed since i huge amount invested in this its really starting to pinch.

Boris_The_Blade 31st October 2007 03:28 AM

I had really erratic problems with my 1510 until I traced it down to dirty control potentiometers and switches. Give those a really good cleaning and see what happens. Lemme know cause I'm curious.

good luck

ashok 31st October 2007 03:29 AM

Could be that the pitch control slider is dirty . You might need to spray a contact cleaner into it to determine that. Better to use one of of those contact cleaners from CRC that leaves no residue or oily deposit. WD40 is something I would not use.
Spray some contact cleaner and move the slider up a down a few times. Do it a few times to ensure the slider is clean.
Cheers.

ashok 31st October 2007 05:19 AM

Also check
http://www.vinylengine.com/library_m..._model=SL-1210


All times are GMT. The time now is 12:29 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2