Thorens TD 125 speed problems - diyAudio
Go Back   Home > Forums > Source & Line > Analogue Source

Analogue Source Turntables, Tonearms, Cartridges, Phono Stages, Tuners, Tape Recorders, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th June 2007, 12:04 PM   #1
diyAudio Member
 
Join Date: Jun 2007
Unhappy Thorens TD 125 speed problems

Hello.

I realize the Thorens TD 125 mkII is known for having a pitch control that wears out. Mine has and I'm desperate to fix. 33 rpm is fine, but 45 runs consistently too fast. Does anyone know how I can fix this problem please. I imagine a change of the electronics controlling the pitch?
  Reply With Quote
Old 20th June 2007, 01:14 PM   #2
diyAudio Member
 
Join Date: Feb 2006
Location: Willy, VIC
Check R22
  Reply With Quote
Old 20th June 2007, 01:17 PM   #3
diyAudio Member
 
Join Date: Jun 2007
Default R22

Sorry, new here, what's R22, or is that a component?
  Reply With Quote
Old 20th June 2007, 11:33 PM   #4
diyAudio Member
 
Join Date: Feb 2006
Location: Willy, VIC
R22 is the variable resistor controlling the frequency of the Wien bridge in the motor controller for 45 RPM. It is the most likely cause of the symptoms you describe.
  Reply With Quote
Old 21st June 2007, 08:28 AM   #5
diyAudio Member
 
Join Date: Jun 2007
Cool thanks. So a replacement resistor should do it?
  Reply With Quote
Old 21st June 2007, 02:59 PM   #6
diyAudio Member
 
Join Date: Aug 2006
Location: Berkshire UK
Default TD125 speed

Hi singing
What I suggest you do is initially mark the positions on to the PCB of all the variable resistor wipers with something indelible, then give them all a squirt of IPA and wind the controls back and forth to clean the tracks and wipers or scrub them with a small stencil brush. Let them dry off, then set all the wipers to their marked positions and you should be very near to the original settings and speeds.

John Caswell
  Reply With Quote
Old 21st June 2007, 07:34 PM   #7
diyAudio Member
 
Join Date: Jun 2007
Default Thanks

Thanks John,

That's most useful - I'll let you know how this goes...

Ed.
  Reply With Quote
Old 25th June 2007, 12:24 PM   #8
diyAudio Member
 
Join Date: Jun 2007
Thumbs up Thanks

Hi John,

As promised some feed back on your advice. The IPA spray, plus some action with a tooth brush worked a treat. 1st time it didn't work so well, so I did it again and re-cleaned. Speed goyt much more stable. I then fine tuned the position of the wipers by moving them very slightly (clock wise and anti clockwise) from underneath the deck and checking to see what affect this had on the speed and pitch control. Some crazy results if you over-do it...

Very happy with the results, thanks for you advice.

Ed.
  Reply With Quote
Old 25th June 2007, 02:07 PM   #9
diyAudio Member
 
Join Date: Aug 2006
Location: Berkshire UK
Default Thorens TD125

Hi Ed,
Well done! Ideally you need a scope and DMM to sort it properly but if it is just dirty controls then this quick and dirty fix often works very well

John
  Reply With Quote
Old 25th June 2007, 02:24 PM   #10
diyAudio Member
 
Join Date: Jun 2007
Learning as I go... I realise the tooth brush was a little bit crude!

I have heard rumours that the 16 rpm setting can be tweaked to run at 78 RPM, is this true, or ill advised?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
thorens td 180 in ....high speed east electronics Analogue Source 0 7th October 2008 09:29 PM
Technics SP-10 speed problems Stefanoo Analogue Source 3 17th August 2008 11:05 PM
Thorens TD 125MKII speed inconsistent? 600LPs Analogue Source 0 26th October 2007 06:32 PM
Technics SP 10 Speed Problems rollinr Analogue Source 26 21st June 2004 07:44 AM


New To Site? Need Help?

All times are GMT. The time now is 10:20 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2