Mark Levinson 380s PreAmp Schematic needed - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th May 2016, 02:52 AM   #1
mgkman is offline mgkman  United States
diyAudio Member
 
Join Date: Nov 2007
Default Mark Levinson 380s PreAmp Schematic needed

Hello, I am trying to troubleshoot a startup problem on my ML 380s Preamp. Can anyone provide a service manual and/or schematic?
  Reply With Quote
Old 19th May 2016, 10:47 AM   #2
diyAudio Member
 
Join Date: Mar 2005
Location: Blaricum
Quote:
Originally Posted by mgkman View Post
Hello, I am trying to troubleshoot a startup problem on my ML 380s Preamp. Can anyone provide a service manual and/or schematic?
I don´t have a factory circuit diagram, but one made by myself of the audio section.
What is the nature of your problem?

380S.jpg

The Buffer of the 380S is equipped with dual transistors, Mat01 and Mat02.

buffer.jpg

Hans
  Reply With Quote
Old 20th May 2016, 05:54 AM   #3
ammel68 is offline ammel68  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Southeast, U.S.
Hans,
Do you have any more details on the buffer such as resistor values, the number of the op-amps used and which transistors in your schematic are MAT01 and which are MAT02?

Also, do you know the V+ and V- voltages?

Thanks...
  Reply With Quote
Old 20th May 2016, 09:13 AM   #4
diyAudio Member
 
Join Date: Mar 2005
Location: Blaricum
Quote:
Originally Posted by ammel68 View Post
Hans,
Do you have any more details on the buffer such as resistor values, the number of the op-amps used and which transistors in your schematic are MAT01 and which are MAT02?

Also, do you know the V+ and V- voltages?

Thanks...
Transistors are Mat02 and mat03, resp dual NPN and dual PNP making the 4 transistors in the buffer.
Opamp is the current feedback amp EL2020
Power supply +/-15V.
I will make a diagram with all details, but have no time for it today.

Hans
  Reply With Quote
Old 20th May 2016, 09:19 AM   #5
diyAudio Member
 
QSerraTico_Tico's Avatar
 
Join Date: Oct 2004
Quote:
Originally Posted by Hans Polak View Post
Transistors are Mat02 and mat03, resp dual NPN and dual PNP making the 4 transistors in the buffer.
Opamp is the current feedback amp EL2020
Power supply +/-15V.
I will make a diagram with all details, but have no time for it today.

Hans
it's already on this forum. I think by peter daniel
\
  Reply With Quote
Old 20th May 2016, 01:59 PM   #6
diyAudio Member
 
Join Date: Mar 2005
Location: Blaricum
Quote:
Originally Posted by QSerraTico_Tico View Post
it's already on this forum. I think by peter daniel
\
Obviously it was on the forum in 2004, but the JPG´s are no longer there.
Hans
  Reply With Quote
Old 20th May 2016, 03:14 PM   #7
diyAudio Member
 
Join Date: Mar 2005
Location: Blaricum
Quote:
Originally Posted by ammel68 View Post
Hans,
Do you have any more details on the buffer such as resistor values, the number of the op-amps used and which transistors in your schematic are MAT01 and which are MAT02?

Also, do you know the V+ and V- voltages?

Thanks...
Here it is

380S_Buffer1.jpg

Hans
  Reply With Quote
Old 20th May 2016, 03:39 PM   #8
diyAudio Member
 
QSerraTico_Tico's Avatar
 
Join Date: Oct 2004
Default no

Quote:
Originally Posted by Hans Polak View Post
Obviously it was on the forum in 2004, but the JPG´s are no longer there.
Hans
No:
(re)searching for a better preamp
  Reply With Quote
Old 21st May 2016, 11:34 AM   #9
diyAudio Member
 
Join Date: Mar 2005
Location: Blaricum
Quote:
Originally Posted by QSerraTico_Tico View Post
This is the buffer scheme for a ML38, not 380S and it is incomplete.
Darlingtons are displayed as single transistors, component values are missing and a 100pF capacitor is missing right after the two 100 Ohm resistors at the input.

Hans
  Reply With Quote
Old 21st May 2016, 07:23 PM   #10
mgkman is offline mgkman  United States
diyAudio Member
 
Join Date: Nov 2007
Thanks Folks, Also been conversing with willcycle offline on this. Im unlikely to tackle the repair myself since I have no electronics experience. The schematic was requested by a local electronics repair shop in Charlottesville, VA but I dont think the guy wants to take this on. The preamp still powers up with seemingly random rapid relay clicks and varying odd characters on the display which seem to have no regular pattern. Its non functional so I have pulled it out of my system until I can get it fixed by a reputable shop. Not crazy about shipping the unit. Trying to choose a shop now. Closest recommended in Springfiled VA 2hrs away. Looking for recommended shop but all have mixed reviews.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
equalizer with a pre Mark Levinson No. 380s audiophile.1963 Solid State 1 22nd May 2016 01:22 PM
Mark Levinson 380S EPROM code willcycle Solid State 0 25th August 2014 10:13 PM
Levinson 380s Preamp on the FRITZ! GRRR! chucker Parts 1 13th January 2012 11:36 PM
Mark Levinson ML1 Preamp Schematic thermionic Solid State 3 26th February 2009 12:26 AM
Mark Levinson 380S Sunsun22 Solid State 10 19th March 2006 09:16 PM


New To Site? Need Help?

All times are GMT. The time now is 09:28 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright ©1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki