ground "loop" type issue with Android phones into class D amps - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th October 2013, 06:04 PM   #1
clong is offline clong  United Kingdom
diyAudio Member
 
Join Date: Jul 2013
Default ground "loop" type issue with Android phones into class D amps

I have terrible noise when plugged into all my class d amps, but it stops the moment music is played. It then returns about 5 seconds after the music stops.

Two questions; one, is this a common problem with android/headphone outputs (I realise it's not actually line level!)? I couldn't find anything googling it.

And 2, will a stereo audio inductor or ground loop isolator solve this problem?

The power supplies are AC to DC so I wonder if this is part of the issue. Is there continuity between DC and and mains earth? (Such a basic question revealing my lack of knowledge)

Thanks
  Reply With Quote
Old 28th October 2013, 08:01 PM   #2
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
I would be tempted to add a low value resistor (well two, one for each channel) across the amp inputs and see if that stops the issue. Class D amps ( the Android not yours, and assuming it uses one) often rely on the headphone or speaker resistance/impedance to form part of the output filter. Try 33 ohms or thereabouts.

(I wouldn't imagine there is any continuity from mains earth to the Android via its own PSU. Does the PSU have a plastic earth prong... assuming its a wall wart ? If in doubt just measure on low ohms range on a DVM from the earth prong to the headphone socket outer. Make sure the Android is "free standing" and not connected to anything else for that test)
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote
Old 28th October 2013, 08:32 PM   #3
FoMoCo is offline FoMoCo  United States
diyAudio Member
 
Join Date: Dec 2012
Since it stops and starts with the music, I'd guess the headphone amplifier IC is powered down when music is not being played to save power. That being the case, the outputs will be indeterminate when stopped or (maybe) paused. You could try a resistor in the 100 ohm range to see if it eliminates the problem.

It's the same solution Mooly proposed, but for a different reason.
__________________
Account Deletion Requested: 1/26/2014
  Reply With Quote
Old 29th October 2013, 11:57 AM   #4
clong is offline clong  United Kingdom
diyAudio Member
 
Join Date: Jul 2013
Thanks for the suggestions- I will try and and get back to you.

Am I putting this in series on both L + R in between the headphone out and amplifier input?
  Reply With Quote
Old 29th October 2013, 12:09 PM   #5
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
No, in parallel, from L and R to ground so that it appears as a load across the audio output of the Android.
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote
Old 29th October 2013, 12:23 PM   #6
clong is offline clong  United Kingdom
diyAudio Member
 
Join Date: Jul 2013
Oh I see! Does this have the side effect of reducing the gain to the amplifier slightly? If so, would it be significant?
  Reply With Quote
Old 29th October 2013, 01:14 PM   #7
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
All it does is appear as a dummy load (as if you had headphones plugged in). It may reduce the signal a little (by how much depends on the output stage of the Android).
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Who bought "Apolsoft Android SMS Transfer" of this software? Can give me some advice? markyorose Software Tools 0 9th April 2013 03:26 AM
"Ground Loop" in Snubberized PSU *fixed* Redshift187 Power Supplies 2 18th March 2012 01:34 AM
YAAGLI - Yet Another Aikido Ground Loop Issue enigma_swe Tubes / Valves 18 26th May 2010 01:03 AM
Possible ground loop issue? atnaat PC Based 4 12th May 2010 01:21 PM
TAS "Class D issue" -opinions. The golden mean Class D 4 13th January 2007 10:27 PM


New To Site? Need Help?

All times are GMT. The time now is 12:42 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2