Linn Kairn repair - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th December 2012, 07:03 PM   #1
diyAudio Member
 
Join Date: Dec 2012
Default Linn Kairn repair

Hello friends,
need some help.
I own a Kairn with a round brilliant sps that is near to die.
Its serial 1612. So it was updatet years ago from linear transformer to that round brilliant sps. I own both now, the brilliant sps(not working) and the linear kairn transformer, i want to use now.
Question: - is it possible to go back easily and set the linear psu instead of brilliant sps?
- Does anyone know the voltage on the secondary side of the linear psu? is it the same like round brilliant? Ther are loose cables on the linear psu.
- Do i have to change the rectifiers or something else?

PLEASE HELP !!

Next days i upload some pics of both psu and my fix of accu on the dislpay side
  Reply With Quote
Old 3rd May 2013, 09:12 AM   #2
diyAudio Member
 
Join Date: May 2013
I recently fixed my Karik brilliant psu and followed the guidance here:

Linn Brilliant SMPS - naked! - pink fish media
  Reply With Quote
Old 3rd May 2013, 07:36 PM   #3
diyAudio Member
 
tiefbassuebertr's Avatar
 
Join Date: Jul 2005
Location: D-55629 Schwarzerden
check also post #5 about
Linn "LINTO" MC Preamp Schematic without SMPS - Schematic for SMPS wanted
  Reply With Quote
Old 19th August 2016, 09:25 AM   #4
diyAudio Member
 
tiefbassuebertr's Avatar
 
Join Date: Jul 2005
Location: D-55629 Schwarzerden
Default Linn Kairn - how works it without Battery ?

The Linn model LK-1 (preamp) works fine even without the 3V6 NiCd battery resp. accu, but follow defaults I note after switch-on:
1) Volume control is "0"
2) No source is selected (mute).
This is good to handle.
By the model "KAIRN-PRO" (without elements on PCB at the phono RIAA section) I read follow after switch-on in the display:
"err2- don't panic innit!"
After this I read under "Volume" the value "0" and after a second it runs up to the value "50".
The selected input (listen) is "tun" (TUNER) and no record input is selected.
Is this behaviour correct and in accordance with the default settings without battery?
Are there other unwanted effects present without battery and is the battery (in opposite to the LK-1) under all circumstances necessary ?
I ask this, because sometimes (not often) the display goes death (even the two strokes are missing), although music is to continue listening. But commands (e. g. volume control, input select and so on) are no longer accepted.

After switch-off and switch-on again it works like previously described.
Thank you for your advices.

Last edited by tiefbassuebertr; 19th August 2016 at 09:32 AM.
  Reply With Quote
Old 19th August 2016, 12:02 PM   #5
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
Send a message via Skype™ to JonSnell Electronic
Battery faulty – if the battery is dead and the unit is switched off, the unit loses its
memory.
On most units, when this happens the unit functions okay afterwards but loses memory. On some units, however the display locks up and must be reactivated
__________________
Support for Flying Mole Class D, Valve Equipment and designs both new and old. www.jonsnell.co.uk
  Reply With Quote
Old 8th September 2016, 05:27 PM   #6
diyAudio Member
 
tiefbassuebertr's Avatar
 
Join Date: Jul 2005
Location: D-55629 Schwarzerden
Default Kairn Screen sometimes going still blank after replace 3V6 NiMH Battery

Now I have replace the battery by a new version, but I still observe the same, as mentioned in my post #1. But all other functions are correct.
This effect with completely dark display occurs unfortunately not often, so that I am not able to perform a troubleshooting.
That reminds me of a frozen screen on my old personal computer while work on it.
I assume, there must be a PIN at the processor, which is very sensitive against spikes on the mains. The internal power supply isn't the SMPS-Version (Brilliant).
Thanks for any advices.
This thread don't provide any advices:
Kairn screen going blank

Last edited by tiefbassuebertr; 8th September 2016 at 05:38 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with linn Valhalla repair ericpeters Analogue Source 37 1st September 2016 04:45 PM
Schematic wanted/LINN KAIRN PRO niamex Analog Line Level 1 30th July 2016 01:24 PM
Linn kairn retro fit linear psu knudsenuk Analogue Source 1 4th April 2012 08:48 PM
Has anyone tried to repair a Linn Ittok (bearings)? Zoodle Analogue Source 6 8th November 2009 08:29 PM
Linn Sizmik sub amp repair - need schematic len_scanlan Solid State 0 13th January 2006 01:31 PM


New To Site? Need Help?

All times are GMT. The time now is 08:43 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki