Test IC TL074 CN - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th September 2012, 02:43 PM   #1
diyAudio Member
 
Join Date: Apr 2012
Default Test IC TL074 CN

Hi.

I'm repairing a AMEK mixing board but i dont have an extensor to power the channel's that i'm fixing.
What i'm doing is comparing some readings on a good channel with the bad channel.

The EQ section of the board as 4 TL074CN IC's, and some are busted, but i dont have a way to see wich are ok and wich are busted because i cant power the circuit.

So i need to do some kind of circuit to test the IC's.
The TL074 brochure has a audio amp circuit (fig.25) wich i can try to replicate, but i have some questions.

Using a DC power supply, should i feed 12V to CC+ and hook up the ground to CC- and feed 6V to ground?

Thnks
  Reply With Quote
Old 7th September 2012, 04:24 PM   #2
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
See this schematic. I use an 18VDC car race wall transformer, and 2 each 1n5344 8v zeners to make +-8v, with the middle of the two zeners the signal ground. I used 22 ohm resistors since the zeners are 5 W rating. If you have a supply with 0, 6, and 12 you could try that but the performance at +-6v doesn't give you much headroom. In that case the 6v point would be the signal ground, you could call the 0 point the -6 v supply. Corners of the 8 pin DIP IC are plus (pin 8) and - (pin 4) voltage.
Attached Files
File Type: pdf schematic-wall-supply-regulator.pdf (82.8 KB, 75 views)
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300
  Reply With Quote
Old 7th September 2012, 04:38 PM   #3
diyAudio Member
 
Join Date: Apr 2012
So i can power the OPs building this?
What values should i use for the caps in your schematic?
The brochure tells me the pins for power are 4(Vcc+) and 11(Vcc-), not pin 8.
  Reply With Quote
Old 7th September 2012, 06:34 PM   #4
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
Obviously your op amps have more than 8 pins then. Go with your datasheet, I'm not going to download a TL074 datasheet. Filter caps can be between 220 uf and 3300 uf, 16 v rated or above, whatever you have laying around. Don't forget to also put .01uf to .47 uf ceramic disk caps between the power supplies and signal grounds near the op amp socket (to prevent oscillation). The plus of the filter caps goes towards the plus of the wall transformer, but if you are not familiar with zener diodes, the line end goes to the resistor connected to the plus of the DC producing transformer. ( When you use regular diodes as rectifiers, the other end goes to the transformer and the line becomes the plus out. If you can only find an AC wall transformer, you would use a rectifier like 1n4007 to the transformer, followed by another electrolytic filter cap to make the 18 VDC).
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300

Last edited by indianajo; 7th September 2012 at 06:41 PM.
  Reply With Quote
Old 9th September 2012, 07:44 AM   #5
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Its very rare for an opamp to fail unless there has been a problem with its power supply.

That said, if you really believe these opamps have failed then they cost peanuts to replace

Before you do that though, do make sure that their power supplies are OK.

A basic test of the opamp can be done in situ by measuring carefully the DC voltages on the two input pins (per opamp) and its output pin. If one input is higher or lower than the other then the output pin will appear to be stuck high or low too. And that could indicate some external component problem.

Failed opamps come way down the list of suspects and if one (or more) has really popped then there will be some contributing factor.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 6th November 2012, 11:20 AM   #6
diyAudio Member
 
Join Date: Apr 2012
Hi guys.
Thanks for the help.
So i changed all the opamps and the problem remains, so it's not a IC thing.

I don't have a way to power the circuit to measure the DC of the two inputs....

What kind of test's can i do on a unpowered circuit (comparing it to a good one) to find a busted component?
  Reply With Quote
Old 6th November 2012, 11:46 AM   #7
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
I suspected as much re the opamps.

Unfortunately comparsion rarely works unless you stumble across an obvious issue such as a short or open circuit.

You need to power this up and do basic voltage tests at the very least. Voltages you can compare one channel to another and that stands a good chance of revealing the problem.

Maybe if you posted some clear pictures of the PCB top and bottom then that (might) help.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 6th November 2012, 11:51 AM   #8
diyAudio Member
 
sofaspud's Avatar
 
Join Date: Nov 2005
Location: San Antonio
An external supply connected to the rails at the normal DC input points should work.
But are you saying that the fault is bad enough that you can't power up the mixer normally?
For an unpowered circuit, you're mostly limited to resistance checks.
__________________
It is error only, and not truth, that shrinks from enquiry. - Thomas Paine
  Reply With Quote
Old 7th November 2012, 12:42 PM   #9
diyAudio Member
 
Join Date: Apr 2012
Hi guys, thanks for the help.

I can power up the mixing board. It's a large studio AMEK mixing board with an external power suply unit.
The channels are detachable from the board, i have to take them out to look (or measure) the components.
Normally this type of desk comes with and extension cord, so that you can power the Ch. of the board and do maintenance, but i dont have one.

I'm doing resistance test and voltage drop test (diode test).
I managed to find a diode that was 200mv off, i changed it but the Equalization section of that ch still does not work.

I'm posting a picture of the EQ. section.
I'm shure the problem is in the eq section cuz I changed this section with one from another Ch, the problem migrated (the ch that was working OK stoped having eq, the ch that had the eq busted started to work properly)

Thanks for the help
Click the image to open in full size.
  Reply With Quote
Old 7th November 2012, 12:56 PM   #10
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Add your pictures to the site,

Too add a photo.

First click "go advanced" in the box below the "quick reply" message box. Doesn't matter if you decide half way through a message to do that, it carries it foward.

Then click "Manage attachements". Maximise the new Window so that you can see all the text.

Click browse in the first box at the top and find your picture. Repeat for any more pictures.
Click upload... a message appears "uploading"
When complete the files will show as being attached. Now click the small text that says "close this window"

The pictures should now be attached and when you submit your post they will appear.

Make sure your pics aren't too big, a couple of 100k is plenty, and many members object when they are massive and it alters the margins
It tells you in the attachments window what max sizes are allowed.


If you want to attach a file that has a non standard format for example excel, circuit simulation etc then try putting the files in a zipped folder and attaching that.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vitavox CN-157 neskor Swap Meet 4 17th October 2012 05:42 AM
how to test ic sagarverma Chip Amps 21 9th November 2005 02:05 PM


New To Site? Need Help?

All times are GMT. The time now is 08:24 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2