Repairing my balanced inputs - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th June 2012, 06:58 PM   #1
gck303 is offline gck303  United Kingdom
diyAudio Member
 
Join Date: Jun 2012
Default Repairing my balanced inputs

One of the 'balanced input' channels on my pre-amp has totally failed. The other channel works perfectly, and the three 'line level' inputs all work fine.

I am not sure how to work out how I can repair this.

There are a couple of SSM2141 chips near the balanced input. Could it be that one of these has died?

Thanks,

George
  Reply With Quote
Old 26th June 2012, 07:15 PM   #2
diyAudio Member
 
Join Date: Nov 2008
Location: Oakmont PA
Pretty much so!
  Reply With Quote
Old 26th June 2012, 07:17 PM   #3
gck303 is offline gck303  United Kingdom
diyAudio Member
 
Join Date: Jun 2012
Okay, thanks.

Is there anyway I can test this before I replace it?
Is it likely to have damaged any capacitors or anything else?
  Reply With Quote
Old 26th June 2012, 10:08 PM   #4
diyAudio Member
 
Join Date: Nov 2008
Location: Oakmont PA
If it partly works I would look elsewhere, but dead is most likely the chip. But do resolder all the connections first.

Also look for the voltage on pin 6. Any DC is a bad sign.
  Reply With Quote
Old 27th June 2012, 05:04 AM   #5
diyAudio Member
 
Join Date: Nov 2009
Location: Los Angeles
They're pretty tough chips but I've had to replace them on rare occasions. Current DigiKey price is $4.40 in singles. If you keep an extra you'll never need it.

G
  Reply With Quote
Old 27th June 2012, 09:14 PM   #6
gck303 is offline gck303  United Kingdom
diyAudio Member
 
Join Date: Jun 2012
I will check the output on pin 6 and compare with the other chip.

This will be tomorrow evening now. So I'll report back one I have done this.

Thanks.
  Reply With Quote
Old 11th July 2012, 09:27 PM   #7
gck303 is offline gck303  United Kingdom
diyAudio Member
 
Join Date: Jun 2012
There are two SSM2141 IC next to each other.

Measuring the DC voltage from ground (on the case) to Pin 6:
Left channel: 0V
Right channel: -13V

So, on the right channel we seem to have nearly the same voltage on pin 6 (output) as on pin 4 (-Vee). Pin 6 is -13V and pin 4 is -14.5V

Does this mean that the SSM2141 chip is kaput and needs replacing?

Thanks, George
  Reply With Quote
Old 11th July 2012, 09:31 PM   #8
gck303 is offline gck303  United Kingdom
diyAudio Member
 
Join Date: Jun 2012
I have measured the voltage. I did this from ground on the case to the pin 6 (output)

Right channel: 0V
Left channel: -13V

Interestingly, this is very close to the voltage on pin 4 (-Vee). -14.5V compared with -13V.

Does this mean that one of my SSM2141s is kaput?

George
  Reply With Quote
Old 12th July 2012, 03:21 PM   #9
diyAudio Member
 
Join Date: Nov 2009
Location: Los Angeles
If it were mine I'd pull the chip, put in a socket and then a new chip. If it's still bad check back.

G
  Reply With Quote
Old 14th July 2012, 06:42 PM   #10
gck303 is offline gck303  United Kingdom
diyAudio Member
 
Join Date: Jun 2012
It worked!!!

I replaced the SSM2141 chip with a new one from Farnell. My Linn RoomAmp is working perfectly.

I am dead chuffed as this was not an expensive piece of kit new. Okay, it do not cost me much at all, but it is really great to have kept it out of the bin.

Thanks all for your help,

George
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TDA7376B AMP with balanced inputs dirtbiker1824 Chip Amps 0 27th February 2011 08:43 PM
balanced inputs DD_Davo Chip Amps 1 4th February 2006 04:29 PM
Simple buffer for balanced inputs? Nisbeth Solid State 6 25th October 2005 06:24 PM
Balanced Inputs on Leach Amp wigginjs Solid State 18 3rd July 2004 08:38 AM
Shorting balanced inputs? dantwomey Pass Labs 10 27th April 2003 09:51 AM


New To Site? Need Help?

All times are GMT. The time now is 08:12 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2