Preamp needed, or am I missing something? - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th April 2012, 02:59 PM   #1
diyAudio Member
 
Join Date: Apr 2012
Default Preamp needed, or am I missing something?

Hi, new here so apologies if I am being dumb or this is in the wrong area..

I am trying to set up a very basic PA system for a garden party. I have 2 Skytek 170.734 Passive speakers connected to a Stageline STA-160 amp via speakon leads.

Can I just connected an iPod straight into this amp via a phono lead and expect it to work? At the moment, all I get is very quiet, bassless sound. Do I need a pre-amp or mixer between the iPod and the Amp?

Help!

Regards - Chris
  Reply With Quote
Old 6th April 2012, 04:02 PM   #2
Simon B is offline Simon B  United Kingdom
diyAudio Member
 
Join Date: Dec 2011
Location: North-East England
Shouldn't need a pre-amp. The fact that you're getting a weak thin sound with no bass suggests that you might have the two stereo halves subtracting from one another perhaps?

Check your lead and ipod by plugging the ipod into another hifi (with volume low!), see what comes out of that. If that's ok, then it's how you're working the amp and speakers that's the problem.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Info - Help Needed ROVSING Parts 4 10th September 2007 09:00 AM
Preamp needed? Stormrider Solid State 0 26th May 2007 12:37 PM
Help needed with preamp. JamesHill Tubes / Valves 15 11th December 2004 06:59 AM
help needed for PREAMP Dj BASS AMP Solid State 7 10th August 2002 08:54 PM


New To Site? Need Help?

All times are GMT. The time now is 11:17 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2