Silicon Chip Pre-amp not switching inputs - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th March 2012, 09:50 AM   #1
Al600 is offline Al600  Australia
diyAudio Member
 
Join Date: Mar 2012
Default Silicon Chip Pre-amp not switching inputs

Hey guys.
I've built myself an Silicon Chip Preamp Kit (Studio Series Pre Amp Input Module Kit | Buy Online | Volt Electronics) and it is not switching between inputs.

When I use the source selector I cannot hear the relays clicking. The module is recieving the right amount of power to the rails and even the IC's but for some reason the relays will not trigger.

Any suggestions?
  Reply With Quote
Old 14th March 2012, 11:38 AM   #2
Al600 is offline Al600  Australia
diyAudio Member
 
Join Date: Mar 2012
Here are some pics of the completed amp.
Attached Images
File Type: jpg 0395 copy.jpg (252.6 KB, 60 views)
File Type: jpg 0396 copy.jpg (203.7 KB, 55 views)
File Type: jpg 0397 copy.jpg (177.6 KB, 55 views)
File Type: jpg 0398 copy.jpg (143.0 KB, 53 views)
File Type: jpg 0399 copy.jpg (143.0 KB, 52 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Silicon Chip ULD Mk3 amp - 0.0006% distortion Circlotron Solid State 50 16th October 2013 02:49 PM
Silicon Chip ULD amp Greg Erskine Solid State 20 18th March 2012 03:47 PM
Silicon Chip July06 / EPE Feb08 Studio Series Pre-Amp with remote and Headphone Amp pgamble Headphone Systems 6 8th November 2009 09:50 AM
silicon chip magazine 15w class a amp jamesfeline Solid State 24 24th May 2007 12:01 PM


New To Site? Need Help?

All times are GMT. The time now is 08:03 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2