EAD theatermaster 8800 problem - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th February 2011, 11:32 AM   #1
diyAudio Member
 
Join Date: Feb 2011
Location: jakarta
Default EAD theatermaster 8800 problem

Hai, my theatermaster 8800 suddenly turnoff from standby mode just like you unplug the power cord!, I didn't have chance to look inside the cabinet yet (still looking for special screwdriver), I think the fuse is blown!, anybody have the same experiance with this mater?, is there any other potensial problem except the fuse?
many thanks
  Reply With Quote
Old 4th March 2011, 08:14 AM   #2
diyAudio Member
 
Join Date: Feb 2011
Location: jakarta
Yap, Its the internal fuse blown, any body have sugestion how this could hapened?, is there any particular component that I should check before changing the fuse?
thanks
  Reply With Quote
Old 25th March 2011, 09:59 PM   #3
diyAudio Member
 
Join Date: Mar 2010
Maybe its nothing. Its very often fuses blow up after several years because they are just old. Change it with no hesitation with a ''slow blow'' one. If its blow again then you have a problem
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EAD DSP7000 any info or schematics? beauty_divine Digital Line Level 0 26th January 2009 07:31 AM
EAD T-7000 CD/LD Player Audio Problem dblack4 Digital Source 0 24th June 2005 04:24 AM
Pioneer SA-8800 RaidersGuy Solid State 0 18th December 2004 05:52 PM
Pioneer SA-8800 Lorne Solid State 13 21st June 2004 08:56 PM


New To Site? Need Help?

All times are GMT. The time now is 07:13 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2