ARC LS25 mkII noise level - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd October 2010, 12:15 AM   #1
diyAudio Member
 
Join Date: Oct 2010
Location: NYC
Default ARC LS25 mkII noise level

What are the expectations on the ARC LS25 mkII noise level? Are these units supposed to be dead quiet in the system?

Mine adds considerable noise to the system. I swapped it out with another preamp (solid state) and the difference is quite significant.
  Reply With Quote
Old 23rd October 2010, 12:36 AM   #2
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
considering that your main amps are 1Vrms sensitivity - maybe best way for you is to use decent attenuator with output buffer ....... because every modern source will give more than enough voltage for full blast , and buffer will add necessary muscles ;

as they say ARCDB - LS25 - 18uV is amount of noise , IHF weighted
are you using proper balanced connection between amp and pre ?
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 23rd October 2010, 02:10 AM   #3
diyAudio Member
 
Join Date: Oct 2010
Location: NYC
Quote:
Originally Posted by Zen Mod View Post
considering that your main amps are 1Vrms sensitivity - maybe best way for you is to use decent attenuator with output buffer ....... because every modern source will give more than enough voltage for full blast , and buffer will add necessary muscles ;

as they say ARCDB - LS25 - 18uV is amount of noise , IHF weighted
are you using proper balanced connection between amp and pre ?
Hi Zen Mod,

I am currently using single ended cables between my LS25 mkII and VS60. VS60 has no balanced inputs.

What does 1Vrms sensitivity imply? That the power amp inputs are too sensitive for the LS25? I figured since they are both ARC, they should be a good match.

And what would be an ideal attenuator be for this set up? Thanks for your patience. I am a bit new to tube hifi amps.
  Reply With Quote
Old 23rd October 2010, 02:19 AM   #4
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Maybe your balanced to unbalanced connection (adaptor, cable) links XLR pin1+3? Some equipment don't take it well, when its a standard in pro connections non the less. All XLR ready made adaptors do that linking. Or there are RCA outputs already?
  Reply With Quote
Old 23rd October 2010, 02:33 AM   #5
diyAudio Member
 
Join Date: Oct 2010
Location: NYC
Quote:
Originally Posted by Salas View Post
Maybe your balanced to unbalanced connection (adaptor, cable) links XLR pin1+3? Some equipment don't take it well, when its a standard in pro connections non the less. All XLR ready made adaptors do that linking. Or there are RCA outputs already?
There is no adapter. The LS25 mkII has single ended outputs too.
  Reply With Quote
Old 23rd October 2010, 02:45 AM   #6
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Change some tubes then and see. One may have gone hissy.
  Reply With Quote
Old 23rd October 2010, 02:55 AM   #7
diyAudio Member
 
Join Date: Oct 2010
Location: NYC
Quote:
Originally Posted by Salas View Post
Change some tubes then and see. One may have gone hissy.
This preamp has 2 x 6H30 tubes. I've already ordered 2 new ones to see if it is the tubes.

I am wondering what the expectation for this preamp might be. Are these preamps supposed to be dead silent? I see the noise spec to be 14 micro volts. IHF weighted. I am going to assume A curve here. It looks like it is quite silent.

I am getting a significant increase in hum and noise when the preamp is taken off mute.
  Reply With Quote
Old 23rd October 2010, 03:00 AM   #8
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Don't know with ARC but I have checked some BAT differentials with 6H30 and they were silent enough. Not like some SS but no problem.
  Reply With Quote
Old 23rd October 2010, 03:10 AM   #9
diyAudio Member
 
Join Date: Oct 2010
Location: NYC
Quote:
Originally Posted by Salas View Post
Don't know with ARC but I have checked some BAT differentials with 6H30 and they were silent enough. Not like some SS but no problem.
I'll have to see. If the new tubes don't help, I'll send it to ARC to make sure it is working correctly.

Perhaps I am not a tube person. I miss the dead quietness of the solid state gear I moved from.
  Reply With Quote
Old 23rd October 2010, 08:06 AM   #10
diyAudio Member
 
analog_sa's Avatar
 
Join Date: Aug 2002
Location: Sofia
Quote:
Originally Posted by GeneJazz View Post
I've already ordered 2 new ones to see if it is the tubes.


Don't hold your breath. The tubes are only used as followers and their contribution to noise is minimal. I have once owned this unit and have no memories of excessive noise but maybe my noise requirements are not so demanding. Otoh, do not judge the sound of high quality tube preamps by the LS25 or any other ARC unit for that matter. Despite what a lot of audiophiles on agon say, they all suck sonically. No opinion about their power amps.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ARC LS25 mkII tube change GeneJazz Analog Line Level 6 18th October 2010 05:09 PM
Squeaky Noise in ARC Dual 75 neddyboy Tubes / Valves 11 6th June 2007 05:58 PM
Noise level swaroopvg Chip Amps 0 11th July 2006 09:24 AM
Help! - Akai GX-95 MkII, Bias, Recording level zstoja Analogue Source 0 25th June 2006 08:49 AM


New To Site? Need Help?

All times are GMT. The time now is 05:02 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2