Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Why is this switch clicking/poping HELP please
Why is this switch clicking/poping HELP please
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th July 2010, 08:55 PM   #1
Joseph R is offline Joseph R  Switzerland
diyAudio Member
 
Join Date: Oct 2008
Default Why is this switch clicking/poping HELP please

Hi,
I have a severe problem i'm triyng to solve since many days now without succes.
I have build a crossover with a switch section before. Please look at the schematic.
Only switch SW2 makes switching noise only when there is a signal. The more bass in signal the more it cliks. No cliks without signal.
I have tried several solutions but with no succes.
I tried to decouple output of U1 and input of U2, U3, U4, U5.
I tried to put a J111 fet controled by sw2 between R9 and -U3, P3 and R9.
I tried a SSM2412 between U1 - R7, P2 - R9, R9 and -U3.
All of this with no succes. It always cliks with a signal.
What is wrong?
Attached Images
File Type: jpg IMAG0174.jpg (317.6 KB, 171 views)
  Reply With Quote
Old 12th July 2010, 09:34 PM   #2
nigelwright7557 is offline nigelwright7557  United Kingdom
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
If only sw2 is clicking then it sounds most likely a wiring mistake.
__________________
PCBCAD51 pcb design software. 2018 version out now. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 13th July 2010, 12:23 AM   #3
Joseph R is offline Joseph R  Switzerland
diyAudio Member
 
Join Date: Oct 2008
I doesnt look like a wiring error. Everything is working fine exept this click/pop. Even when I use sw2 only to control the fet or the ssm2412 it clicks but only when there is a signal.
another guess?
  Reply With Quote
Old 16th July 2010, 08:01 AM   #4
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Why is this switch clicking/poping HELP please
Clicks occur because of an abrubt change in DC conditions.
Check the DC output of each opamp output pin under no signal conditions... it must be 0.000volts DC.
What opamps are they ? if bipolar then the change in DC input impedance will cause a click as the bias currents are significant with bipolar devices.

Also you say "the more bass" the more it clicks. It will because you are switching the signal abrubtly at some non defined point in amplitude (seen as a sudden DC shift by the opamp input)... and the lower frequencies are where most of the energy is. There's no way round that with a simple circuit like this.
  Reply With Quote
Old 22nd July 2010, 11:01 PM   #5
DF96 is online now DF96  England
diyAudio Member
 
Join Date: May 2007
sw2 just happens to have more switch bounce/dirty contacts than the others? Are all the switches grounded at exactly the same point?
  Reply With Quote
Old 24th July 2010, 02:38 PM   #6
Bonsai is offline Bonsai  Europe
Account disabled at member's request
 
Join Date: Jul 2003
Location: Europe
Sounds like a DC offset problem to me. Check the wiring around SW2 very carefully.
  Reply With Quote
Old 24th July 2010, 05:41 PM   #7
Joseph R is offline Joseph R  Switzerland
diyAudio Member
 
Join Date: Oct 2008
About dc offset it is 0.2mv so this is not the problem.
About dirty contact or loose switch I tried to replace the switch with no succes.
I have build another switch board and the problem on this other board is on SW3, with same click pop noise with signal.
The ground is in star shape and sw2 is the closest to ground connection.
  Reply With Quote
Old 24th July 2010, 05:50 PM   #8
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Why is this switch clicking/poping HELP please
But you say it clicks only when signal present. My reply in post#4 outlines why this happens.
  Reply With Quote
Old 26th July 2010, 05:21 AM   #9
abraxalito is offline abraxalito  United Kingdom
diyAudio Member
 
abraxalito's Avatar
 
Join Date: Sep 2007
Location: Hangzhou - Marco Polo's 'most beautiful city'. 700yrs is a long time though...
Send a message via Yahoo to abraxalito
Quote:
Originally Posted by Joseph R View Post
All of this with no succes. It always cliks with a signal.
What is wrong?
In point of fact, that's how switches work - they create abrupt changes in level, which sounds bad when music plays. So you have a couple of choices:

a) Wait for a zero crossing of the waveform and only switch at that point
b) Replace the switch by a variable attenuator and ramp up and down slowly

If you search for the solid state volume controls (e.g. Cirrus, Dallas/Maxim, TI) you'll see in their datasheets that they generally implement a) to avoid clicks at volume level changes. I'd say you'd need to implement both a) and b) to make your clicks go away entirely.
__________________
'The total potential here must be nothing less than astronomical.'
'Nothing less. The number 10 raised almost literally to the power of infinity.'
  Reply With Quote
Old 26th July 2010, 09:54 AM   #10
Bonsai is offline Bonsai  Europe
Account disabled at member's request
 
Join Date: Jul 2003
Location: Europe
Mooly is right on this.
  Reply With Quote

Reply


Why is this switch clicking/poping HELP pleaseHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Krell CD player makes poping noise when shut down gto127 Digital Source 0 19th October 2009 06:26 PM
Ok need amp help poping / cracking on left channel intechpower Car Audio 2 22nd November 2008 03:05 PM
poping soundings leander Solid State 44 1st November 2005 01:48 AM
Help!! Poping easyrider Chip Amps 3 27th February 2004 01:46 PM


New To Site? Need Help?

All times are GMT. The time now is 05:05 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki