Yet another Volume controlers and source selections - Page 75 - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th September 2012, 11:45 PM   #741
diyAudio Member
 
FarmTech's Avatar
 
Join Date: Mar 2010
Location: Hjørring Denmark
Send a message via MSN to FarmTech Send a message via Skype™ to FarmTech
hi,
look at this layout to backlight !!

Click the image to open in full size.
__________________
/Kim - Bascom-AVR user >> My WebChat
My Web Site
  Reply With Quote
Old 18th September 2012, 05:25 AM   #742
atupi is offline atupi  Romania
diyAudio Member
 
Join Date: Oct 2010
Location: Bucharest
It's the same. On my schematic i'm not using that 10ohm resistor between C and E of transistor. I told you my problem is that on pin 17 for uC i'm not detecting any change so the uC is not triggering the transistor from my point of view.

I have tested also your software from post #277 wich is very nice.

I must say i'm totally begginer in microcontrollers.
  Reply With Quote
Old 18th September 2012, 05:39 AM   #743
diyAudio Member
 
Join Date: Mar 2007
Location: Bandung
Quote:
Originally Posted by atupi View Post
It's the same. On my schematic i'm not using that 10ohm resistor between C and E of transistor. I told you my problem is that on pin 17 for uC i'm not detecting any change so the uC is not triggering the transistor from my point of view.

I have tested also your software from post #277 wich is very nice.

I must say i'm totally begginer in microcontrollers.
Try exchange pin 15-16

Didiet
  Reply With Quote
Old 18th September 2012, 10:05 AM   #744
atupi is offline atupi  Romania
diyAudio Member
 
Join Date: Oct 2010
Location: Bucharest
I suppose your are suggesting to xchange de pins of LCD who powers the backlight but they are correctly connected as the backlight works when i'm shorting C-E of transistor.
  Reply With Quote
Old 18th September 2012, 02:47 PM   #745
diyAudio Member
 
FarmTech's Avatar
 
Join Date: Mar 2010
Location: Hjørring Denmark
Send a message via MSN to FarmTech Send a message via Skype™ to FarmTech
a simple test code to see if the backlight pin is working

this turn on off every 5 sec

Code:
$regfile = "m8515.dat"
$crystal = 8000000
$hwstack = 32
$swstack = 10
$framesize = 40
config portd.7 = Output
Portd.7 = 0


'Test code

do
Set PORTD.7
wait 5
Reset PORTD.7
wait 5
loop
__________________
/Kim - Bascom-AVR user >> My WebChat
My Web Site
  Reply With Quote
Old 18th September 2012, 03:03 PM   #746
diyAudio Member
 
Join Date: Mar 2007
Location: Bandung
From Danzup code, pin 17, it should be 5V (Logic 1) when power on and 0V when power off. Did you measure it?

Didiet
  Reply With Quote
Old 18th September 2012, 11:00 PM   #747
atupi is offline atupi  Romania
diyAudio Member
 
Join Date: Oct 2010
Location: Bucharest
Thanks Farmtech your code was very helpful. I had problems hardware and software. After installed Farmech's test soft i noticed even i have 5v on pin 17 still no light so i decided to replace BC517 Darlington with a simple generic NPN and it worked.
After this with Danzup sofware still no light but gues what Danzup invited me to his home to solve the issues (we are living in the same are but never met each other) and we solved almost everything. Remained the final test: sound In sound OUT to see how it perfoms.

Danzup is a great guy !
  Reply With Quote
Old 19th September 2012, 05:35 AM   #748
Vikt0r is offline Vikt0r  Ukraine
diyAudio Member
 
Join Date: Jul 2005
Location: Uzhgorod, Ukraine
Send a message via ICQ to Vikt0r Send a message via Skype™ to Vikt0r
Hi, atupi! We'll find your problem easily - just point me to the software your'е using - I also remember I've found small inconsistencies in the program while debugging mine (earlier in this thread). So, what's your firmware?
*****
Oh, sorry, you've got that really fast What was the real issue, apart from damaged transistor?

P.S. Danzup is a great guy indeed!

Last edited by Vikt0r; 19th September 2012 at 05:38 AM. Reason: Subject changed
  Reply With Quote
Old 19th September 2012, 07:39 AM   #749
danzup is offline danzup  Romania
diyAudio Member
 
danzup's Avatar
 
Join Date: Oct 2007
Location: Bucuresti
Quote:
Originally Posted by Vikt0r View Post
Hi, atupi! We'll find your problem easily - just point me to the software your'е using - I also remember I've found small inconsistencies in the program while debugging mine (earlier in this thread). So, what's your firmware?
*****
Oh, sorry, you've got that really fast What was the real issue, apart from damaged transistor?

P.S. Danzup is a great guy indeed!
The issue was that in software was another pins from another port used for backlight and connections.
__________________
There are not better tube than 6P3S and 6N2P for my ears !
  Reply With Quote
Old 30th September 2012, 09:59 PM   #750
atupi is offline atupi  Romania
diyAudio Member
 
Join Date: Oct 2010
Location: Bucharest
Here is my work in progress. I recicled a box from an old sattelite receiver but it fits well a would say.
Software is not fully functional but after all hardwork a will meet Danzup again for fine tuning.
Schimbarea surselor o fac tot din encoder insa incep sa cred ca ar fi mai elegant sa folosesc cele 2 taste SUS-JOS neutilizate de pe panoul frontal.
The analogic part of PGA is made using two simple shunt regulators using LM317 as CCS.
Click the image to open in full size.

Click the image to open in full size.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
source selector / volume hum in Aikido cbutterworth Tubes / Valves 1 28th March 2007 08:34 AM
Source for volume knobs? Alois Pass Labs 4 3rd July 2005 06:12 PM
IC Controlers for Class D Power stage frozenpod1 Class D 14 17th May 2005 04:25 PM
Swichable source and volume pot. Whats the best way? sounder Chip Amps 2 22nd September 2003 07:29 PM
detented volume pots... source? Mach_Y Parts 2 1st June 2003 06:23 PM


New To Site? Need Help?

All times are GMT. The time now is 03:30 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2