Yet another Volume controlers and source selections - Page 62 - diyAudio
Go Back   Home > Forums > Source & Line > Analog Line Level

Analog Line Level Preamplifiers , Passive Pre-amps, Crossovers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd September 2011, 12:58 PM   #611
Leon08 is offline Leon08  Germany
Banned
 
Join Date: Sep 2010
Location: at Home
Looks like this problem is not easy to solve.
  Reply With Quote
Old 23rd September 2011, 09:37 AM   #612
diyAudio Member
 
Pryanick's Avatar
 
Join Date: Nov 2009
Location: Minsk
Send a message via ICQ to Pryanick
Default Audible Clicking

Why not so easy?
1. Routing ground on PCB in a right way.
2. Recalc all Res values to make Rin and Rout lower down to 600 Ohm (for example)
3. Use RC circuit for each relay (for coil contacts)
4. Make a delay for relais switching (if you have a source code)
5. Avoid capacitive load (I think this is the hardest part of this problem)
  Reply With Quote
Old 23rd September 2011, 01:34 PM   #613
Leon08 is offline Leon08  Germany
Banned
 
Join Date: Sep 2010
Location: at Home
Quote:
In the design of the RelaiXed2 this effect was significantly lowered by:
●having a PCB ground shield between the digital relay control lines and the audio circuits on
top
●using 5V relays, instead of the otherwise probably more desirable 12V relays. Still, the effect
still remains.
So if it is so easy then why "the effect still remains"? And this man was an engineer by Philips, so if he cannot solve this problem ,then it must be very hard to solve.
  Reply With Quote
Old 23rd September 2011, 01:42 PM   #614
diyAudio Member
 
Pryanick's Avatar
 
Join Date: Nov 2009
Location: Minsk
Send a message via ICQ to Pryanick
Default Audible Clicking

When I solder my R/2R VC version I check if it will take place...
  Reply With Quote
Old 23rd September 2011, 01:46 PM   #615
diyAudio Member
 
Join Date: Mar 2010
Default Preamp with Real Time Clock

Has anyone did a digital volume control or preamp with Real time clock?
  Reply With Quote
Old 23rd September 2011, 02:18 PM   #616
Leon08 is offline Leon08  Germany
Banned
 
Join Date: Sep 2010
Location: at Home
Quote:
Originally Posted by alexisk10 View Post
Has anyone did a digital volume control or preamp with Real time clock?
Yes, I build one.
  Reply With Quote
Old 23rd September 2011, 10:07 PM   #617
diyAudio Member
 
Pryanick's Avatar
 
Join Date: Nov 2009
Location: Minsk
Send a message via ICQ to Pryanick
Quote:
Originally Posted by alexisk10 View Post
Has anyone did a digital volume control or preamp with Real time clock?
I have one too
  Reply With Quote
Old 24th September 2011, 10:34 AM   #618
diyAudio Member
 
Join Date: Mar 2010
how did you manage the time when you increasing or decreasing the volume and the other functions.

My problem is when i increasing or decreasing the volume, the clock is show up between the numbers, when the rc5 remote control sends a low pulse.

this is the subroutine for the Time:
Sub Datetime:
Do
Locate 1 , 5
Lcd Time$
Locate 2 , 5
Lcd Date$
Waitms 1
If Command > 128 Then
Exit Do
End If
Goto Begin
Loop
End Sub
  Reply With Quote
Old 24th September 2011, 01:18 PM   #619
Leon08 is offline Leon08  Germany
Banned
 
Join Date: Sep 2010
Location: at Home
In my preamp the clock is shown only when in standby mode.
But in your case you must do some code optimisation.I need to see the complete code or the whole main loop to say you exactly how to do it.This is only one procedure which is called and there are also other procedures wich interfere with it.
This procedures and commands are executed one after another.
But I'm not experienced in this language.
Maybe you must simply change the order of execution and the problem disapears.
  Reply With Quote
Old 25th September 2011, 04:29 PM   #620
diyAudio Member
 
Pryanick's Avatar
 
Join Date: Nov 2009
Location: Minsk
Send a message via ICQ to Pryanick
Well,
today I soldered relay board and wrote some BAS-code for R/2R VC, only vol up/dn, on/off and input sel subs, connected each other and started testing about audible clicking.
I can say that I heared only ONE click at -31dB in full range (from -127dB to 0dB) but only when volume does UP from -32dB.
When volume goes down from -30dB to -32dB - no click.
Then I solder WIMA-0.1 on signal input and that click is disappeared (may be a little bit DC were in audio channel).
Now I have R/2R clicks-free VC...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
source selector / volume hum in Aikido cbutterworth Tubes / Valves 1 28th March 2007 08:34 AM
Source for volume knobs? Alois Pass Labs 4 3rd July 2005 06:12 PM
IC Controlers for Class D Power stage frozenpod1 Class D 14 17th May 2005 04:25 PM
Swichable source and volume pot. Whats the best way? sounder Chip Amps 2 22nd September 2003 07:29 PM
detented volume pots... source? Mach_Y Parts 2 1st June 2003 06:23 PM


New To Site? Need Help?

All times are GMT. The time now is 02:43 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2