diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Analog Line Level (http://www.diyaudio.com/forums/analog-line-level/)
-   -   switch noise (http://www.diyaudio.com/forums/analog-line-level/138834-switch-noise.html)

kffern 18th February 2009 11:00 AM

switch noise
 
Hi,
I am wiring up a Rega (Premotec) motor using a 0.22uF 240v cap and 8K resistor.
It works very well but I get a click through the system when I turn the SPST switch on. I think I should be fitting a cap across the switch or a MOV across the live and neutral. I'm not sure which or the correct values.
Can someone help?

Thanks,
Kffern

tubenut 21st February 2009 03:46 AM

Try 0.01 mfd over the switch but use a suitably rated cap.

I think the reason Rega do not fit one may be that using just the SPST with a cap across it allows may allow a little current flow through the motor etc even in off position.
Linn, on their basic supply, used caps on the switch but they used a DPST for live and neutral.

kffern 22nd February 2009 12:21 AM

Thanks Tubenut,

I should have known as my Lenco has a 0.0039 uF cap across the spst switch. Finding such a low value is difficult but I can get a 0.01uf X2 cap quite cheaply. It's actually for a Luxman A522 which I converted to a Rega motor with bearing/subplatter.

Regards,

Kffern


All times are GMT. The time now is 01:23 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2