Go Back   Home > Forums > > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

AKSA Builders of market proven kits and modules at sound quality to rival the best in high end

Reply
 
Thread Tools Search this Thread
Old 2nd October 2012, 04:30 PM   #1011
syklab is offline syklab  United States
diyAudio Member
 
Join Date: Jul 2009
Location: This world
Can anyone help to explain what went wrong with my Fetzilla? the fuse didn't got blown, only R22 and R24. What could be drawing a large current that will cause this? I check at the PCB and cannot locate if there is any component had shortened. What should I check next time when I power it up after replacing R22 and R24?

Thanks
  Reply With Quote
Old 2nd October 2012, 04:49 PM   #1012
smartx21 is offline smartx21  Brazil
diyAudio Member
 
Join Date: Mar 2010
Location: Santiago, RS/ Brasil
Send a message via MSN to smartx21 Swordfishy/ASPEN FETZILLA power amp
Maybe wrong trimmer position during first power-on?
__________________
Regards,
Max.
  Reply With Quote
Old 2nd October 2012, 05:17 PM   #1013
syklab is offline syklab  United States
diyAudio Member
 
Join Date: Jul 2009
Location: This world
Quote:
Originally Posted by smartx21 View Post
Maybe wrong trimmer position during first power-on?
Trimmers were set and check during the initial test before moving to the case.
  Reply With Quote
Old 2nd October 2012, 07:28 PM   #1014
pinnocchio is offline pinnocchio  Canada
diyAudio Member
 
pinnocchio's Avatar
 
Join Date: Sep 2010
Location: Montreal
Were's Hugh?

Haven't seen him for some time now

Do
__________________
PREAMPs : Bal AMB α10 + JC-80 | Bal DCB1 | Bal LDR3x | AMPs: AMB β24 | USSA3 & 5 | FO v1.4 | TGM8 | VZ Audio NS OPS | NX Amp | FC-100
DACs : TPA Buffalo II + OPC's NTD1 I/V | JLsounds | Mirand AK4490 + Discrete Output Speakers : Troels Gravesen ATS-4 | Sagwee LT V3
  Reply With Quote
Old 2nd October 2012, 07:55 PM   #1015
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Swordfishy/ASPEN FETZILLA power amp
Quote:
Originally Posted by pinnocchio View Post
Were's Hugh?

Haven't seen him for some time now

Do
Hugh has been rather poorly these last few weeks but hopefully on the mend now.

I'm sure I speak for all in wishing him a continued recovery and hopefully we can look forward to seeing him back on the forums.
  Reply With Quote
Old 3rd October 2012, 11:12 AM   #1016
Nico Ras is offline Nico Ras  South Africa
diyAudio Member
 
Nico Ras's Avatar
 
Join Date: Nov 2005
Location: East Coast of South Africa
Could you accidentally reversed the PSU connections. It happens to the best of us.
__________________
Kindest regards
Nico
  Reply With Quote
Old 3rd October 2012, 11:54 AM   #1017
ncc is offline ncc
diyAudio Member
 
Join Date: Jul 2006
Location: VN
Send a message via Yahoo to ncc
Quote:
Originally Posted by syklab View Post
Can anyone help to explain what went wrong with my Fetzilla? the fuse didn't got blown, only R22 and R24. What could be drawing a large current that will cause this? I check at the PCB and cannot locate if there is any component had shortened. What should I check next time when I power it up after replacing R22 and R24?

Thanks
Hi skylab,

I got the same problem before. You could read my post at:

Fetzilla Build Documentation
Post #80 onward and see how I discovered the problem
  Reply With Quote
Old 3rd October 2012, 12:36 PM   #1018
syklab is offline syklab  United States
diyAudio Member
 
Join Date: Jul 2009
Location: This world
Quote:
Originally Posted by ncc View Post
Hi skylab,

I got the same problem before. You could read my post at:

Fetzilla Build Documentation
Post #80 onward and see how I discovered the problem
Hi ncc,
Thanks for the information ang Hugh had explained it well. I had made the exact mistake when I connect both channel to one transformer, I will replace the resistors and try again this weekend report back.

Thanks for everyone's help.
  Reply With Quote
Old 10th October 2012, 08:20 AM   #1019
AndrewT is offline AndrewT  Scotland
R.I.P.
 
Join Date: Jul 2004
Location: Scottish Borders
Use a bulb tester for every power up of a new, or modified, mains powered project.
__________________
regards Andrew T.
  Reply With Quote
Old 16th November 2012, 12:48 PM   #1020
rho is offline rho  Belgium
diyAudio Member
 
Join Date: Sep 2003
Location: Peer, Belgium
I'm sorry if this is already made clear somewhere in the previous 101 pages, but I have a simple question about this amp: Is it designed to drive a 4 ohm load? Or can I drive a 4 ohm load when lowering the supply voltage?

Sorry for my laziness, but I didn;t feel like plowing trough 100 pages of replies to find the answer.
  Reply With Quote

Reply


Swordfishy/ASPEN FETZILLA power ampHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aspen Headphone Amp AKSA AKSA 1147 13th January 2018 03:41 AM
Aspen Maya Vegking AKSA 7 17th May 2011 05:02 AM
DIYaudio to become new Aspen Forum AKSA AKSA 13 2nd May 2011 07:04 AM
Sachiko/aspen slab rmcelroy Full Range 0 9th March 2011 06:34 PM
Aspen HAKSA Group Buy AKSA AKSA 74 16th November 2010 05:17 AM


New To Site? Need Help?

All times are GMT. The time now is 04:40 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki