Go Back   Home > Forums > Blogs

Old

Hiphonics Zxi 1008 amp repairs almost completed

Posted 9th February 2016 at 11:38 AM by tscr2015

The customers original problem with this amp was that it had no sound on one of the two channels, after replacing various components in the amp section and the power supply section it turns out that all it was, was a bad crossover selector switch. The contacts had broken on the inside of the switch. Sourcing this switch is a problem because most companies carry it but you have to buy like 100 or more at $.40/ea. Did find that I can get one from Mouser electronics next month. So in the mean time for testing purposes I hard wired the contacts in the switch together with solder until I can get a new switch.

Stay tuned....
diyAudio Member
Posted in Uncategorized
Views 495 Comments 0 tscr2015 is offline
Old

Repairs to Fender PD250 Complete

Posted 3rd January 2016 at 02:36 AM by tscr2015

While after about 6 months of working on my Fender PD-250 PA System, I finally got it back together tonight and it works great. I don't think that I am going to mess with it any more.

Thanks to everyone on the forums for the help and suggestions. This should be ready to rock the parade season this coming year. Right now I can vibrate the floors of my office/work area with about quarter volume.

Stay tuned to this as I work on the Hiphonics zxi1008 amp that I have on the bench now.

Till then Have a good one
Tom
diyAudio Member
Posted in Uncategorized
Views 295 Comments 0 tscr2015 is offline

New To Site? Need Help?
Copyright 1999-2017 diyAudio